The back/forward buttons in Firefox 3.5 are buggy with 1.2 RC1

VERIFIED FIXED

Status

Mozilla Labs Graveyard
Personas Plus
VERIFIED FIXED
9 years ago
a year ago

People

(Reporter: flore, Assigned: myk)

Tracking

Details

Attachments

(1 attachment)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; fr; rv:1.9.1b4) Gecko/20090423 Firefox/3.5b4
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; fr; rv:1.9.1b4) Gecko/20090423 Firefox/3.5b4

With the personas 1.2RC1, the back/forward buttons are incorrectly displayed, i.e. there seems to be a part of another button on the right side (with large or small icos, the problem is the same).

Reproducible: Always

Steps to Reproduce:
1. Install personas 1.2RC1 on Firefox 3.5b4 on Mac
2. The back/forward buttons is not correctly displayed


Expected Results:  
The button should be the same size and aspect as without personas.
(Reporter)

Comment 1

9 years ago
Created attachment 381828 [details]
back/forward buttons incorrectly displayed
(Assignee)

Comment 2

9 years ago
I see this too on Firefox 3.5b4, although I don't see it on the latest nightly.  I suspect that this is because the fix we made to make Personas work with the recent changes to the Firefox 3.5 back/forward buttons regresses their appearance on Firefox 3.5 builds with the old-style buttons.

I bet there's a way to fix this, so we don't hork all the users on 3.5b4.  I think we just need to include the -moz-image-region rules for the buttons in the Personas skin for Mac.
Assignee: cbeard → myk
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
(Assignee)

Comment 3

9 years ago
Fixed <http://hg.mozilla.org/labs/personas/rev/49788d212ce2> and pushed development build with fix <http://people.mozilla.com/~cbeard/personas/dist/personas-dev.xpi>.

I fixed this, per comment 2, by including the -moz-image-region rules for the core toolbar buttons in the Personas skin for Firefox 3.5 on Mac OS X.

As a side effect, this may improve Personas compatibility with third-party themes that specify their own toolbarbutton icon, since Personas might still override them, but at least when it does so it'll override both the image file and the region within the image where the icon is to be found.
Status: ASSIGNED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
(Reporter)

Comment 4

9 years ago
That's OK for me.
Thanks Myk
(Assignee)

Updated

9 years ago
Duplicate of this bug: 497239
verified fixed
Status: RESOLVED → VERIFIED
Product: Mozilla Labs → Mozilla Labs Graveyard
You need to log in before you can comment on or make changes to this bug.