Assertions in x64 abcasm/mops.abs, abcasm/coverage/I.abs

VERIFIED FIXED

Status

--
major
VERIFIED FIXED
9 years ago
9 years ago

People

(Reporter: cpeyer, Assigned: stejohns)

Tracking

unspecified
x86_64
All
Bug Flags:
in-testsuite +
flashplayer-qrb +

Details

(Reporter)

Description

9 years ago
A win x64 assertion and mac ppc 64 assertion in the smoke tests started in rev 1978:

Win64 is an assert in abcasm/mops.abc: Assertion failed:
"((IsRCObject(rc)))" (".\\GC.cpp":3029)avmplus crash: exception 0x80000003
occurred

Mac64_ppc assertion:

Assertion failed: r->isPtr()
(/Users/build/buildbot/tamarin-redux/mac64-intel/tamarin-redux/core/CodegenL
IR.cpp:439)
Abort trap

According to Steven, injection occurred due to Bug 494013
Flags: in-testsuite+
Flags: flashplayer-qrb?

Comment 1

9 years ago
The mops assert is also observable with mactel64 in the Debug_Debugger configuration.  Running under GDB it appears that MethodEnv::newfunction() simply picks up *core->dxnsAddr and passes it as the dxns value to the ScopeChain::create function, but that value is junk (0xbababa....baba).  newfunction was in this case called from the interpreter.
(Assignee)

Comment 2

9 years ago
This is definitely fixed by https://bugzilla.mozilla.org/show_bug.cgi?id=496473 -- there are still minor issues with the patch for that but it is likely to land within a day or two.

Updated

9 years ago
Flags: flashplayer-qrb? → flashplayer-qrb+

Comment 3

9 years ago
Steven, status?
(Assignee)

Comment 4

9 years ago
Pushed long ago. Closing.
Status: ASSIGNED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED

Comment 5

9 years ago
confirmed that testcases pass on win64 and ppc64, removing entry from testconfig.txt, pushed 2688:0c3ef35ebc9f
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.