Check for update over the command line

VERIFIED DUPLICATE of bug 318855

Status

()

enhancement
VERIFIED DUPLICATE of bug 318855
10 years ago
10 years ago

People

(Reporter: asolkar, Unassigned)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: DUPEME)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1b4) Gecko/20090423 Firefox/3.5b4
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1b4) Gecko/20090423 Firefox/3.5b4

On my Linux desktop, Firefox (nightly build) is installed in /opt directory with root privileges. This is used by more than one users. When I run Firefox, Help -> Check for Updates... menu is grayed out - because I do not have enough privileges I assume. I am reluctant on running Firefox as root just to update it.


Reproducible: Always

Steps to Reproduce:
1. Install as root for multiple users to use
2. As a non-root user, try to update firefox (Help -> Check for Updates ...)
Actual Results:  
(Help -> Check for Updates ...) is grayed out for a non-root user, since root installed Firefox. To update Firefox, root must start Firefox and update it via (Help -> Check for Updates ...)

Expected Results:  
Wouldn't it be handy for firefox (and other mozilla apps) to have a command line argument to update Firefox? Something like 'sudo firefox --update'.
Component: General → Application Update
Product: Firefox → Toolkit
QA Contact: general → application.update
Whiteboard: DUPEME
Version: unspecified → Trunk
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 318855

Updated

10 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.