Saved passwords not available

RESOLVED WORKSFORME

Status

()

Toolkit
Password Manager
RESOLVED WORKSFORME
9 years ago
9 years ago

People

(Reporter: Andy Burns, Unassigned)

Tracking

1.9.1 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1pre) Gecko/20090603 Shiretoko/3.5pre
Build Identifier: 3.5b99

I've been using 3.54b for some time, and more recently shiretoko nightly builds (up to 20090603 Shiretoko/3.5pre) today I tried out 3.5b99 and noticed it was not using my saved passwords, they don't show up at all under tools/options/security/saved passwords.

I reloaded newest shiretoko instead of 3.5b99 and the passwords were all available (using the same profile)


Reproducible: Didn't try
Andy, were you using a different profile while you tried 3.5b99?

I installed Fx3.5b4, saved a few passwords, installed a 3.5nightly, upgraded to the latest nightly, the passwords were still there; then I installed 3.5b99 and the passwords were still there, and I could use them to login to those sites. I was using the same profile for all of these scenarios.
Component: Security → Password Manager
Product: Firefox → Toolkit
QA Contact: firefox → password.manager
Summary: Save passwords notavailable → Saved passwords not available
Version: unspecified → 1.9.1 Branch
(Reporter)

Comment 2

9 years ago
(In reply to comment #1)

> Andy, were you using a different profile while you tried 3.5b99?

No, the same profile I used for 3.0.x, 3.5b4 and with nightlies (I have backups!).

After I filed the bug report, I switched back to 3.5b99 and the passwords were available again, so far they haven't become unavailable yet, I first noticed the issue when the xmarks extension started prompting for authentication out of the blue.
maybe something with an extension.
(Reporter)

Comment 4

9 years ago
I do have several extensions  installed, all what I'd call "common" ones, and none have to forced to load by adjusting maxver.

The password issue has just occured again, seems to happen after starting and then leaving private browsing mode.
With over 6000 extensions, there are no "Common ones" Can you create a new profile and try to to reproduce there?
Calling this WFM, since there have been no other reports and it's working for you. (And me :).

If it happens again, please reopen and attach some debugging per https://wiki.mozilla.org/Firefox:Password_Manager_Debugging
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WORKSFORME

Comment 7

9 years ago
I have the Same Problem. Yesterday i upgraded from 3.0.0.11 to 3.5

All my htaccess passwords are not shown in the password Manager and the pw´s are not autofilled in the Formulars... 

But they are still saved in my profile and can be accessed by older Versions of Firefox (i tried FF 3.0.7  (there are the passwords accessible)

The htaccess passwords are also not exported in FF 3.5

i exported all passwords with the 3.0.0.7 and tried to import them in the 3.5 
The htaccess pw´s are still not shown in the list. 

I entered the passwords manualy in the Formulars and i got asked if the 3.5 should save the information. (i clicked yes) and now the htaccess passwords are saved and accessible.
You need to log in before you can comment on or make changes to this bug.