show total download speed, number of downloads, total remaining time in download manager

RESOLVED DUPLICATE of bug 812894

Status

()

--
enhancement
RESOLVED DUPLICATE of bug 812894
9 years ago
5 years ago

People

(Reporter: eyaler, Unassigned)

Tracking

(Depends on: 1 bug)

Trunk
x86
All
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b4) Gecko/20090423 Firefox/3.5b4 (.NET CLR 3.5.30729)
Build Identifier: 

show total download speed in download manager

Reproducible: Always

Steps to Reproduce:
1. download multiple files
2. open download manager
3.
Actual Results:  
no indication of total download speed

Expected Results:  
display total download speed
(Reporter)

Comment 1

9 years ago
if the total download speed will be displayed in the download manager window, we may also want to add the total number of downloads and total time remaining, which already appear in the download status bar but not in the download manager window itself. these seem relevant to appear as a summary in the download manager itself, especially if an pause/resume all button will be added in the future as in Bug 399908

alternatively the total download speed may be added to the download status bar or at least as a tooltip when hovering above the download status bar
(Reporter)

Updated

9 years ago
Status: UNCONFIRMED → NEW
Depends on: 399908
Ever confirmed: true
Summary: show total download speed in download manager → show total download speed, number of downloads, total remaining time in download manager
Version: unspecified → Trunk
(Reporter)

Comment 2

5 years ago
updates:
total time remaining is now implemented in the indicator icon.
total download speed was discussed and rejected in bug 812894.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Depends on: 812894
Resolution: --- → DUPLICATE
Duplicate of bug: 812894
(Reporter)

Updated

5 years ago
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---

Updated

5 years ago
OS: Windows XP → All

Comment 3

5 years ago
(In reply to eyal gruss (eyaler) from comment #2)n.
> total download speed was discussed and rejected in bug 812894.

Bug 812894 is about redesigning the download items to add the download speed,
and it has not been rejected, we want to do that. So, that is a duplicate of
this bug according to the description in comment 0.

Displaying the number of downloads is something we don't plan to do, to avoid
cluttering the user interface. You may file a different bug if you want to
discuss this further, but it's likely it won't pass triage or UI-review.
Status: REOPENED → RESOLVED
Last Resolved: 5 years ago5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 812894
You need to log in before you can comment on or make changes to this bug.