Copying events between calendars can lead to an error

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
9 years ago
9 years ago

People

(Reporter: w.beyer, Unassigned)

Tracking

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.9.0.10) Gecko/2009042316 Firefox/3.0.10
Build Identifier: Mozilla Sunbird Version 0.9

Copying an event to an other calendar via drag and drop, shifting it to an other date and then copying it back to the first calendar leads to an error. The error does not occur if the primary event is deleted before copying back the second event.

Reproducible: Always

Steps to Reproduce:
1. Create calendars A and B and an event in calendar A.
2. Mark calendar B.
2. Copy the event to calendar B via drag and drop.
3. Move this event within calendar B to an other date via drag and drop.
4. Copying the resulting event back to calendar A via drag and drop.

Actual Results:  
Event is not copied but message "Error number: MODIFICATION_FAILED" is displayed.

Expected Results:  
Copying without error message.
Wolfgang, is this still reproducible with a recent Sunbird 1.0pre nightly build?
(Reporter)

Comment 2

9 years ago
I just tried the nighly built from 2009-11-25: Transferring an event to an other calendar via drag and drop seems to be no longer possible at all. This was already mentioned in https://bugzilla.mozilla.org/show_bug.cgi?id=496814. So concerning this problem things obviously became even worse than better.

But on the other hand the problem described in this report can no longer be reproduced ;-).
Sounds like bug 179484, patch is in review I believe. Closing this bug since the original problem is wfm.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.