Firefox auto-complete wrong fields with stored username/password

RESOLVED DUPLICATE of bug 499223

Status

()

Toolkit
Password Manager
--
major
RESOLVED DUPLICATE of bug 499223
9 years ago
9 years ago

People

(Reporter: Jérémie Horhant, Unassigned)

Tracking

1.9.0 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; fr; rv:1.9.0.10) Gecko/2009043001 Gentoo Firefox/3.0.10
Build Identifier: Mozilla/5.0 (X11; U; Linux x86_64; fr; rv:1.9.0.10) Gecko/2009043001 Gentoo Firefox/3.0.10

For a domain all password inputs are filled with the same stored password. And worse, all text field preceding a password field are treated like if they were username fields.

Reproducible: Always

Steps to Reproduce:
1. Type username and password on a website authentication page
2. Tell firefox to store username/password
3. Go to an other page with an input field for a password which is not related to the first step password 
Actual Results:  
On a domain all password input are filled with the same password whatever the input field name.

Currently on my web site admin are filling user nicknames and user password with there own username and password which is really annoying.

Expected Results:  
For a domain when a user store a username and a password form field firefox should only auto complete fields with the same name value.

Assuming that username is always just before password input field is really a bad idea.

For example : This is my first bug report there so I have create my bugzilla account. I clicked on the confirmation mail to finish the account création. My email address is written first then realname field and password field. I filled all and tell firefox to store this autentication. But when i return to the login page firefox filled username and password fields whith my real name and the password. That obviously doesn't work username is not my real name but my email address.
Component: General → Password Manager
Product: Firefox → Toolkit
QA Contact: general → password.manager
Version: unspecified → 1.9.0 Branch
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 499223
You need to log in before you can comment on or make changes to this bug.