TM: Google gravity much slower on ARM when JIT enabled

RESOLVED WORKSFORME

Status

()

Core
JavaScript Engine
RESOLVED WORKSFORME
9 years ago
7 years ago

People

(Reporter: romaxa, Unassigned)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: chromeexperiments, URL)

(Reporter)

Description

9 years ago
Open URL on some arm device, and check how it works with and without JIT enabled.

When JIT is disabled URL finish gravity ~20 sec... (~1 sec for one gravity update)
When JIT is enabled gravity works very slow (~20 sec for one gravity update) and it seems is not going to finish at all..

Comment 1

9 years ago
This can probably be reproduced on intel as well, so we should try to analyze it there.
i ran a few with jit on and off on mac intel minefield and finally crashed.

bp-6b8c9125-b874-4add-8216-13b1b2090608 at 
TraceRecorder::snapshot  	 js/src/jstracer.cpp:2440

Comment 3

9 years ago
That demo is using box2d.js, so it's probably a duplicate of bug 479090 (however, I never saw a crash when trying other box2d.js demos).
I was able to repeat the crash bp-6b8c9125-b874-4add-8216-13b1b2090608 while keeping jit fixed to true then repeatedly reloading the page.

Comment 5

9 years ago
Is this a dup of bug 486302?

Updated

8 years ago
Whiteboard: chromeexperiments
Runs nicely on x86. romaxa, is this still a problem with JM?
Romaxa, ping?
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.