Closed Bug 496894 Opened 12 years ago Closed 11 years ago

Very old bug: Mime decoding of mailto: does not function

Categories

(Thunderbird :: General, defect)

x86
Windows XP
defect
Not set
major

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 468351

People

(Reporter: elmue, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.2; de; rv:1.8.1.6) Gecko/20070725 Firefox/2.0.0.6
Build Identifier: versión 2.0.0.21 (20090302)

This bug is very old and very serious.
It was already in Thunderbird 1.5 and it is incredible that it is still not fixed.

Mime encoded umlauts in the name of a recipient result that ALL recipients in the mailto: are ignored and Thunderbird opens with a completely empty email window.

Reproducible: Always

Steps to Reproduce:
First Step:
First check the correct behaviour:
In the Windows start menu under Execute enter 
"C:\Program Files\Thunderbird\Thunderbird.exe" -osint -compose "mailto:Peter%20Mueller<pmueller@hotmail.com>,John%20Goldwin<jgoldwin@yahoo.com>"

Now you see what you expect: Thunderbird opens the mail compose window with the email addresses of Peter Mueller and John Goldwin.

Second Step:
Now the bug:
Do the same with 
"C:\Program Files\Thunderbird\Thunderbird.exe" -osint -compose "mailto:Peter%20M%FCller<pmueller@hotmail.com>,John%20Goldwin<jgoldwin@yahoo.com>"

Note that I only replaced "ue" with "%FC" which is a Mime encoded "ü".
Peter Mueller becomes
Peter Müller

What happens now ?
The mail compose Window opens with NO email AT ALL!
ALL "To:" fields appear completely empty.
Even John Goldwin who was not modified and who worked correctly before does NOT appear anymore.

How is it possible that a Mime encoded Space ("%20") is decoded correctly and a Mime encoded ü ("%FC") causes a completely empty window to open?

If you want to send an email to 50 persons via a mailto: link, and only ONE of these 50 persons has an umlaut in his name, NONE of the 50 recipients will be displayed.
You have to enter them all manually.

This is 100% sure a severe bug.
It was already in Thunderbird 1.5 since multiple years.
You can reproduce it 100%.
I hope it will be fixed soon.

Actual Results:  
as described above

Expected Results:  
as described above

as described above
Whiteboard: dupme
(In reply to comment #0)
> Note that I only replaced "ue" with "%FC" which is a Mime encoded "ü".

Wrong.
MIME requires a charset, which you didn't specify.
Encoding ü as %FC assumes that the charset is ISO-8859-1 (or similar), but we require UTF-8, i.e. you have to encode ü as %C3%BC - and then it works.

(And, btw, the fact that we treat the comma as a delimiter regardless of quotes is a bug as well.)
Status: UNCONFIRMED → RESOLVED
Closed: 12 years ago
Resolution: --- → INVALID
Hello

OK.
But do you think that the behaviour which results of a missing charset definition is correct?

If there is one unknown character in a list of 50 emails you see an empty window opening?
Do you think Thunderbird should behave like that?

I make to suggestions:
1.) 
If charset is unknown a character like "%FC" is replaced with a question mark and the 50 emails are displayed as good as possible. (best solution)
2.) 
An error message is displayed which says that the charset must be defined.(worse solution)

This would lead the programmers of webpages directly to the cause of their error instead of having to post bugzilla reports.

My programs ALWAYS show an error if something is wrong.
A behaviour like in Thunderbird (opening an empty window) only causes frustration at the side of the user!

So it IS a bug that an empty window opens.
The user should know what is wrong!

Elmü
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---
Hello

How do I write a "mailto" Link which functions on Thunderbird and on Outlook Express (which expects an "ü" as "%FC")?

Elmü
Reporter could be a dupe of bug #415368?
Elmue this bug seems a dupe of bug #468351.

Feel free to reopen it if with latest TB 3.1 you can reproduce it.
Status: UNCONFIRMED → RESOLVED
Closed: 12 years ago11 years ago
Resolution: --- → DUPLICATE
Whiteboard: dupme
Duplicate of bug: 468351
You need to log in before you can comment on or make changes to this bug.