Garbage collection is very long

RESOLVED WORKSFORME

Status

()

Core
JavaScript: GC
RESOLVED WORKSFORME
9 years ago
a year ago

People

(Reporter: Franck, Unassigned)

Tracking

({perf})

Trunk
x86
Windows XP
Points:
---
Bug Flags:
blocking1.9.2 -

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: DUPEME)

Attachments

(1 attachment)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; fr; rv:1.9.0.10) Gecko/2009042316 Firefox/3.0.10
Build Identifier: trunk

Calling JS_GC() (or destroying the last context) take a very long time (more than 10sec on my computer) after the following script:
  for ( var i = 0; i < 100000; i++ ) [1];

program:
  http://code.google.com/p/jslibs/source/browse/trunk/src/tools/jsTest.cpp#134


Reproducible: Always
(Reporter)

Updated

9 years ago
Version: unspecified → Trunk

Updated

9 years ago
Flags: blocking1.9.2?
(Reporter)

Comment 1

9 years ago
Created attachment 382178 [details]
call stack when pressing pause in VC during the GC
(Reporter)

Comment 2

9 years ago
This only happens when I launch the program in visual studio.

Updated

9 years ago
Flags: blocking1.9.2? → blocking1.9.2-

Updated

9 years ago
Keywords: perf

Updated

8 years ago
Whiteboard: dupme
Whiteboard: dupme → DUPEME
(Assignee)

Updated

4 years ago
Assignee: general → nobody

Updated

2 years ago
Component: JavaScript Engine → JavaScript: GC
Status: UNCONFIRMED → RESOLVED
Last Resolved: a year ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.