If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Mozilla "forgets" Profiles every start

VERIFIED FIXED

Status

Core Graveyard
Profile: BackEnd
P3
blocker
VERIFIED FIXED
17 years ago
2 years ago

People

(Reporter: Niko Pavlicek, Assigned: racham)

Tracking

({pp})

Trunk
x86
Windows 98

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [dogfood+] (have fix))

(Reporter)

Description

17 years ago
Build ID 2000-08-21-04 (Win32-installer) forgets the user profiles every start.

Steps to reproduce:
1. Create, migrate a Mozilla Profile.
2. Start Mozilla with this Profile. You can change all settings etc. The files 
are changing, too.
3. Quit Mozilla.
4. Restart the Profile Manager: There are no avaible Profiles!

And, in my opinion, there should be the profile I used the last time, I used 
Mozilla :-)

Comment 1

17 years ago
Works for me on Linux 2000-08-21-06

Comment 2

17 years ago
I cannot reproduce this on Win/Linux/Mac (mozilla builds)- 2000821
Niko, 
How are you relaunching?
(Reporter)

Comment 3

17 years ago
I quit with "File -> Quit" and than I use the shortcut in the startmenu 
(Programs -> Mozilla Seamonkey -> Profile Manager).

Comment 4

17 years ago
reassigning to racham.
Assignee: putterman → racham

Comment 5

17 years ago
same problem for me on 2000082108
(Assignee)

Comment 6

17 years ago
If this is real, this sounds like an update problem. However, the profile
information is saved and the registry is updated as sson as the migration
activity is finished. So, it could be something other than update issue too..I
will check on my debug build today (NT) and verfiy the behavior.

Comment 7

17 years ago
Bhuvan,
I can reproduce this on my Win98 machine mozilla build 2000082108- Win2000 and 
WinNT are ok.

Comment 8

17 years ago
*** Bug 49719 has been marked as a duplicate of this bug. ***

Comment 9

17 years ago
*** Bug 49706 has been marked as a duplicate of this bug. ***

Comment 10

17 years ago
adding Tracy Walker to cc list
(Assignee)

Comment 11

17 years ago
So, looks like this is a real problem (Windows98. I don't see it on my NT box).
So, we need to start with builds on or before Aug16th and verify if this still
occurs.

That would give us some clue as to whether or not moving profile registry to new
HOME location is a root cause of this problem.
(Reporter)

Comment 12

17 years ago
it didn't happen on builds until 2000/08/20.
I had problems in the builds before (like bug #49585: can't send eMails), but I 
don't think these were/are related issues.

Updated

17 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 13

17 years ago
mark dogfood since this can be a big problem if profiles are lost upon each 
launch.
Keywords: dogfood
(Assignee)

Comment 14

17 years ago
Though we don't know what is exactly causing this regression, first look at the
behavior after running it on win98 suggests that directory service is not able
to locate application registry and returns nothing........weirdness started
happening on today's builds only (need to look at yesterday's checkins too...!)
..if you notice the console, it throws javascript component failure exception
errors. (only win98).

I am going to debug this on Sean Su's win98 machine. Build has been just kicked
off..
Status: NEW → ASSIGNED

Comment 15

17 years ago
I see this on win98, 082108 as well.

Comment 16

17 years ago
Putting on [dogfood+] radar.
Whiteboard: [dogfood+]
(Assignee)

Comment 17

17 years ago
Sean Su's machine hung yesterday. I am going to try again today.

Meanwhile, Grace, plaese verify that this occurs on win98.

thanks

Comment 18

17 years ago
this is listed as blocker.  is this a smoketest blocker I should hold the tree
closed for?
(Assignee)

Comment 19

17 years ago
winNT behaves properly even today...Going to Grace's desk to check win98..
If it happens again && If checking win98 behavior is part of daily smoke tests, 
this will be tree blockcer..

Comment 20

17 years ago
this is occurring on Win98- 
on launch from install- with 1 4.x profile, automigration takes place, empty 
activation page comes up, N6 launches, I can send mail.  2nd launch using 
-profileoption from command line, shows the migrated profile, displays the 
correct activation pages (splash screen and activation form) and launches but 
now the mail folders are gone (bug 49767) 

Cleaned users50, mozregistry.dat Mozilla/registry.dat and created a second 4.x 
profile- relaunched with -installer option and profilemanager was blank- no 4.x 
profiles displayed, created a profile, launched, closed and relaunched with 
-profilemanager - newly created profile does not display- same as bug summary
(Assignee)

Comment 21

17 years ago
As this is not happening on winNT platform used by most developers for 
development, I don't think we should hold tree for this bug unless QA says 
otherwise. It is going to take time to debug and nail down the root cause as 
it turns out to be a single OS version (win98) case..
 

Comment 22

17 years ago
*** Bug 49845 has been marked as a duplicate of this bug. ***

Updated

17 years ago
Keywords: pp
(Assignee)

Comment 23

17 years ago
I have fix for this. just checking the behavior on NT with this fix now. Will 
check it soon...
Whiteboard: [dogfood+] → [dogfood+] (have fix)
(Assignee)

Comment 24

17 years ago
*** Bug 49767 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 25

17 years ago
Fix checked in. If no HOME setting found, registry.dat will be stored in the 
windows directory (under Mozilla subdirectory).

alas..! registry was homeless lately on windows98 and caused all these problems. 
File Service has started returning null for HOME on win98. So, that case needed 
to handled so that registry will always a home.
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago

Comment 26

17 years ago
FYI...bug 49945 was determined to not be a migration bug, but a symptom of this
bug.  In bug 49945 the 4.7 prefs.js file was being edited after closing
seamonkey the 2nd time after you have migrated the pref.  That is fixed with
today's build (08-23-08) so this the fix for this bug probably fixed bug 49945
too.  

Comment 27

17 years ago
build 2000082304M18 on Win98
Status: RESOLVED → VERIFIED
mid-air collision ? / bugzilla cleanup
Reopening (current State: verified and no resolution
Status: VERIFIED → REOPENED
fixed
Status: REOPENED → RESOLVED
Last Resolved: 17 years ago17 years ago
Resolution: --- → FIXED
verified
Status: RESOLVED → VERIFIED
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.