If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

<VIDEO> tag broken since yesterday

VERIFIED WORKSFORME

Status

()

Firefox
General
--
critical
VERIFIED WORKSFORME
8 years ago
8 years ago

People

(Reporter: Alistair MacDonald, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.2a1pre) Gecko/20090608 Minefield/3.6a1pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.2a1pre) Gecko/20090608 Minefield/3.6a1pre

Yesterday I created about 5 video examples for a talk I'm giving on Thursday about Firefox 3.5, today none of the examples work, and my code has not changed. I also tried this on XP and have the same results.

Here's the error:
[Exception... "Component returned failure code: 0x804b0002 (NS_BINDING_ABORTED) [nsIStreamListener.onStartRequest]"  nsresult: "0x804b0002 (NS_BINDING_ABORTED)"  location: "JS frame :: file:///C:/Users/F1LT3R/AppData/Roaming/Mozilla/Firefox/Profiles/jvtax4gw.FireFox2/extensions/firebug@software.joehewitt.com/components/firebug-channel-listener.js :: anonymous :: line 126"  data: no]
file:///C:/Users/F1LT3R/AppData/Roaming/Mozilla/Firefox/Profiles/jvtax4gw.FireFox2/extensions/firebug@software.joehewitt.com/components/firebug-channel-listener.js
Line 126

At first this looks like a FireBug error, but even if I turn Firebug off it does not work. Audio seems to work no problem.



Reproducible: Always

Steps to Reproduce:
1. Add tag to HTML, <video "whatever.ogv" autoplay...
2. Load HTML
3. Watch nothing happen
Actual Results:  
Results, none, or a Firebug error. Minefield Windows also not closing properly, can't tell if that is related or not.

Expected Results:  
It should see video. I saw it yesterday. Now nothing!

Wonder if this will be fixed by Thursday?

Comment 1

8 years ago
Works for me with Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.2a1pre) Gecko/20090608 Minefield/3.6a1pre and Firebug 1.5a03

If you need a reliable browser I suggest not using Minefield builds, they chose that name for a reason. Things will break. If you need a reliable build https://developer.mozilla.org/devnews/index.php/2009/06/08/firefox-35-preview-now-available-for-beta-users/ should be good. There are very few features that are in Minefield and not in 3.5 and performance is very similar. Additionally you may need to give Firefox's safe mode or a new profile a try http://support.mozilla.com/en-US/kb/Basic+Troubleshooting
(Reporter)

Comment 2

8 years ago
I installed the Beta from the link you provided but I'm still not getting any video at all.

Comment 3

8 years ago
Work through the basic troubleshooting doc. Every public <video> element that uses ogg files has worked for me. 

Is it possible to provide the file you are trying to play?
(Reporter)

Comment 4

8 years ago
Just wanted to apologize for being REALLY dumb and wasting your time! The demos I had created, all ran from my desktop, I then moved these to my server, and completely forgot about setting the MIME-type .ogv.

But hey... great to know there's always a Mozilla guy with some good advice when you're racking you brains at 2am.  Hahaha, I can't believe it, I was like... man... I didn't change a thing? Did I? No I didn't (Well not any code) But I did change the location! DUH *smacks forehead*
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WORKSFORME

Comment 5

8 years ago
Yes, Firefox won't follow links that point to files on the local file system. A bit of background at http://kb.mozillazine.org/Links_to_local_pages_don%27t_work
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.