If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

"Recent pages" triangle in navigation bar is grayed out when there are pages to go back or to go forward to

RESOLVED INVALID

Status

()

Firefox
Theme
RESOLVED INVALID
8 years ago
6 years ago

People

(Reporter: dex_sf, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1b99) Gecko/20090605 Firefox/3.5b99
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1b99) Gecko/20090605 Firefox/3.5b99

When you open a tab, load a page and follow a link in it, the "recent pages" triangle in the navigation toolbar stays grayed out although it's active. 

Reproducible: Always

Steps to Reproduce:
1. go to http://www.mozilla.com/en-US/
2. click on "learn more"

Actual Results:  
"recent pages" triangle grayed out

Expected Results:  
"recent pages" triangle should be black to display button is active

Updated

8 years ago
Blocks: 494832
Component: General → Theme
QA Contact: general → theme
This style is expected and was changed in bug 494832 a couple of days back. It has not a disabled look. Compare it with the one when you open a new tab. It is a bit lighter now.

Alex, we wanna stay with this color? When I compare it with the triangles used in Safari it is really a bit too lighten.
(Reporter)

Comment 2

8 years ago
Oh right, it is slightly darker. In my opinion it should be adjusted to the colors of the back and forward buttons. At least the triangle should be significantly darker than the grayed out forward button next to it.
I'm going to dupe this bug over to bug 494832 so discussion occurs in one place.  The short version is that this type of control is totally foreign to unified toolbars on OS X to begin with, and we want it to be subtle, but not overly confusing.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 494832
This can't be a duplicate of bug 494832, as it was filed after that one was fixed. If it's wontfix, please mark it so.
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---

Comment 5

8 years ago
FWIW:  When I upgraded from 3.5b4 to 3.5b99 yesterday I noticed this graphic change.  I've not been running nightly builds so for me the visual change in this little tiny dropdown is a bug and I came here to report it.

After reading the discussion on the other bug thread that its a visual design decision to go with the light triangle is a mistake.  Usability is important and while I see the difference when I open a new tab (the triangle almost disappears),  I think it should be re-evaluated.

I understand that its supposed to be the same color as the light gray circle to resize the search bar, but given that these two elements are far apart on the bar and that the triangle is functionally tied to the history forward/back buttons, it needs to be visually tied to them as well.  Since the grayed out forward/back buttons are the same color, it signels to the user that its disabled as well.

The circle color doesn't matter much.  It looks like your typical Apple circle but the triangle is visually "disabled".

Usability needs to win out over style.
The "recent pages" dropdown doesn't exist anymore.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago6 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.