Closed Bug 497103 Opened 12 years ago Closed 12 years ago

Update list of MPL Initial Developers in about:licence for Firefox 3.5

Categories

(Firefox :: General, defect)

3.5 Branch
defect
Not set
major

Tracking

()

RESOLVED FIXED

People

(Reporter: gerv, Assigned: gerv)

References

Details

(Keywords: fixed1.9.1)

Attachments

(1 file, 1 obsolete file)

I had entirely forgotten that we needed to do this until an old bug reminded me :-(

about:licence contains a list of everyone whose name is in an Initial Developer block in the source tree. This is to comply with the I'm-Netscape-look-at-me provisions in MPL section 3.3. The list was last updated for Firefox 3 in bug 414025 and, before that, for Firefox 2 in bug 380017. It needs updating again.

Gerv
Attached patch Patch v.1 (obsolete) — Splinter Review
Here's the patch. Some important things to note:

a) This is a compliance thing, not a credit mechanism. The proper credit mechanisms are about:credits and Help | About. This is a list of people who happen to have created new files from scratch in the Mozilla codebase. It is not supposed to be some definitive list of important contributors. So if your name is or isn't in this list, don't sweat it.

b) It was created by running a script over mozilla-central. Last time we did this, it ran over the entire tree. The result of this is that the patch removes the names of some mail/news hackers who happen not to be the Initial Developer of any files outside mail/news. See a) for why this is not a big deal right now.

c) However, b) will present problems in the future because I think Thunderbird now uses the same license file as Firefox (yay!). Before Thunderbird does a final release, I will need to adapt the script to make it possible to run it over multiple repositories, or something like that. But given the tight Firefox timescales (sorry, again) I thought I should get this out here ASAP.

Gerv
Assignee: nobody → gerv
Status: NEW → ASSIGNED
Nominating for blocker status.

Risk: text-only change to HTML file displayed by Firefox. Not even changing any markup.

Reward: compliance with the MPL.

Gerv
Flags: blocking-firefox3.5?
Connor: can you shepherd this through?
Flags: blocking-firefox3.5? → blocking-firefox3.5+
Attached patch Patch v.2Splinter Review
Here's v.2, with the names from comm-central merged in.

Note again: this is only Initial Developers, which is the list that the MPL requires. It's not a list of all copyright holders. This does mean that some very important developers, who happen never to have originated a file, will not be there. And other important developers, who happened to have originated a single file for the last release, but that file has now been removed, will also be removed in this patch. Please don't take it personally. :-)

Gerv
Attachment #382297 - Attachment is obsolete: true
Attachment #382309 - Flags: review+
Attachment #382309 - Flags: approval1.9.1+
Looks like that doesn't include the comm-central satellites like Chatzilla and DOMi, which isn't a problem for Fx or Tb but SeaMonkey's going to have to remember to redo it (on what will be a stable branch by then, fun).
> <!-- This list created from the entire Mozilla source tree on 2007-05-30.
>      It was created using a modified version of the "relic" script in
>      tools/relic, along with the make-id-list script in the same directory. -->    

This comment seems incorrect, since the list was generated very recently by looking at mozilla-central and comm-central, which are not "the entire Mozilla source tree" (see Phil's comment above).

I also assume that no-one has created a file on mozilla-1.9.1 that's not also on mozilla-central, and vice versa?
Smokey: I'll fix the comment on checkin. Thanks :-)

Phil: in which repository are those codebases?

Gerv
DOMi is in its own repo, Chatzilla's still in CVS - the easiest way to get all of SeaMonkey's code is just the |python client.py co| step from https://developer.mozilla.org/en/Comm-central_source_code_%28Mercurial%29
Pushed to mozilla-central and mozilla-1.9.1:

http://hg.mozilla.org/releases/mozilla-1.9.1/rev/f308c18a0a75
http://hg.mozilla.org/mozilla-central/rev/5d1bf7e2c8dd

Gerv
Status: ASSIGNED → RESOLVED
Closed: 12 years ago
Resolution: --- → FIXED
(In reply to comment #5)
> Looks like that doesn't include the comm-central satellites like Chatzilla and
> DOMi, which isn't a problem for Fx or Tb but SeaMonkey's going to have to
> remember to redo it (on what will be a stable branch by then, fun).

I'm not so sure this is a real problem any more when shipping them as pre-installed add-on that are listed in the add-ons manager, as we don for SeaMonkey 2 now. Gerv, what's the legal context here? Is it enough to have their stuff in the extension or do we need them in this license file?
Duplicate of this bug: 497744
KaiRo: I think that it makes most sense for add-ons to do their own MPL compliance. Perhaps about:license should be extensible by add-ons, but we aren't there yet...

Gerv
(In reply to comment #12)
> KaiRo: I think that it makes most sense for add-ons to do their own MPL
> compliance. Perhaps about:license should be extensible by add-ons, but we
> aren't there yet...

If that applies to shipped-with-the-product extensions (I read your comment to mean that), we are safe by just looking at comm-central and mozilla-[1.9.1|central] for the license.html list.
You need to log in before you can comment on or make changes to this bug.