The context menu option GetSelectedMessages is disabled until menu popup occurs

RESOLVED DUPLICATE of bug 374261

Status

--
minor
RESOLVED DUPLICATE of bug 374261
9 years ago
8 years ago

People

(Reporter: jmdiazarg, Unassigned)

Tracking

x86
Windows Vista

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 6.0; Trident/4.0; SLCC1; .NET CLR 2.0.50727; Media Center PC 5.0; .NET CLR 3.5.30729; .NET CLR 3.0.30729)
Build Identifier: 2.0.0.21 (20090302)

I've setted some email accounts to retrieve just headers from the server to get desired messages on demand by selecting those messages, clicking the list with the secondary button and selecting GetSelectedMessages from the contextual menu.
This option remains disabled on the menu until any of the four options with popups activates a secondary popup menu

Reproducible: Always

Steps to Reproduce:
1.From the list of messages select one or more messages
2.click on them with the secondary mouse button
Actual Results:  
See the option GetSelectedMessages disabled

Expected Results:  
If the message wasn't completely downloaded, this option must be enabled

After "Steps to Reproduce" position the mouse cursor over the menu option MoveTo, CopyTo, Tag or Mark until the secondary popup shows
Jaun, please, could you answer to comment #1 (use official TB 3.0.x release)
Whiteboard: closeme 2010-05-25
(Reporter)

Comment 3

8 years ago
I've installed the new version since that report, i don't remember precisely wich version was but 2.x.
Now i have version 3.0.4 wich works slightly different but there is a similar bug.
The thing is like this now:

The same configuration that before, this is just download the headers of the mails not the content so later i can delete those messages that i don't want to download.
Well, after all message headers were downloaded i have a bunch of headers without content on my inbox, some i will delete and the rest i want to download the content. At this point i select those messages on my inbox to batch download by using the context menu "Get selected messages".
Well this menu element is disabled when you open TB and stays like that until you workaround it like follows.
Select the messages you want the content to download.
Click the menu File->Offline-Get Selected Messages

Once you do that the content will download (of course) and the context menu that was disabled now is enabled.
Then there is no need to use the workaround.
(Reporter)

Updated

8 years ago
Version: unspecified → 2.0

Updated

8 years ago
Whiteboard: closeme 2010-05-25

Comment 4

8 years ago
Great, now in 3.1 the 'Get Selected Messages' option doesn't work at all until I go via the [File, Offline, Get Selected Messages] route.
This is surely a regression and an even worse bug.

Given that downloading emails is Thunderbird's primary purpose, I'm a little puzzled as to why this bug still isn't assigned.

Anyone?

Updated

8 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 374261
You need to log in before you can comment on or make changes to this bug.