Strange bar occurs when dragging tab to bookmark

RESOLVED DUPLICATE of bug 419930

Status

()

--
minor
RESOLVED DUPLICATE of bug 419930
9 years ago
9 years ago

People

(Reporter: genuinem22-bugger, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b99) Gecko/20090605 Firefox/3.5b99
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b99) Gecko/20090605 Firefox/3.5b99

It happens nearly every time when I try to reproduce it.
1. Drag the tab to the bookmarks sidebar
2. Drag the tab back (ie away from the bookmarks sidebar)

It's a bit hard to describe the whole process by words only. It takes some skills to reproduce this bug every time. To increase the chance to see the strange bar, try to dragging the tab up and down, dragging faster and suddenly dragging away from the bookmarks sidebar.

It doesn't have to be fast. I can see the strange bar even if I drag slowly.

This is the screenshot from the bookmarks sidebar (see what's inside the red circle):
http://img134.imageshack.us/img134/9876/bookmarkdragtrace.gif

Reproducible: Always

Steps to Reproduce:
It happens nearly every time when I try to reproduce it.
1. Drag the tab to the bookmarks sidebar
2. Drag the tab back (ie away from the bookmarks sidebar)
Actual Results:  
The strange bar is left forever. It won't disappear even if you close and reopen the bookmarks sidebar. A restart would remove that bar.

Expected Results:  
The bar shouldn't be here
(Reporter)

Comment 1

9 years ago
Created attachment 382398 [details]
Strange bar shows up
that indicator is the sidebar drop indicator, i'm pretty sure this is a dupe, dragging away fast from the sidebar does not send to the tree a consumable event, so the drop indicator is not cleaned up.

If you start another drag in the sidebar it should go away.
Severity: normal → minor
Whiteboard: dupeme

Updated

9 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 419930

Updated

9 years ago
Whiteboard: dupeme
You need to log in before you can comment on or make changes to this bug.