Closed Bug 497288 Opened 13 years ago Closed 5 years ago

Restart needed for special folder icons (like junk,archive) to update in folderpane tree

Categories

(Thunderbird :: Mail Window Front End, defect)

defect
Not set
minor

Tracking

(Not tracked)

RESOLVED WORKSFORME

People

(Reporter: Aureliano, Unassigned)

References

Details

Attachments

(1 file)

Attached image screenshot
After the new archives folder icon is landed, when create a new archives folder, her has a wrong icon ("normal" sub-folder icon).

Restarting TB, all work fine.

see screenshot for details.
Blocks: 488061
No longer depends on: 488061
AFAIK this is intentional.
I believe it's known, but not intentional per se.
Not a huge issue, but I wouldn't call this desired behavior.
Bug 100239, at least for seamonkey, dunno if it's back or front end...
OS: Windows XP → All
Hardware: x86 → All
Summary: Restart needed for archives folder icon in folderpane tree → Restart needed for special folder icons (like junk,archive) to update in folderpane tree
Target Milestone: Thunderbird 3 → ---
I could observe same phenomenon of "icon of special folder is icon for ordinal folder upon folder creation" on Drafts(Templates too) with next build, but I couldn't see "restart needed(mandatory)" part.
> Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.4pre) Gecko/20090925 Shredder/3.0pre

[Steps to reproduce]
(1) Dummy POP3 account is defined(no Global Inbox use).
    Copies&Folder setting is set as Drafts of the account by default.
(2) Drafts folder is not created by account creation, restart,
    viewing of Copies&Folders settings followed by click of OK.
    (It's by design change.)
(3) Create folder named "Drafts" -> icon of ordinal folder.
(4) Context menu of account/folder, Open -> new window is opened.
    -> Icon of Drafts folder is changed at the new window.
In latest nightly build, it looks simple folder pane refresh issue.
Just seen with TB 3.0.4:

When changing the "Sent" folder of an account or identity, sometimes the icons also do not change (from yellow folder to/from blue stamp (on windows)).

If you move the mouse over the tree row, they are updated.
(In reply to Philippp from comment #7)
> Just seen with TB 3.0.4:
> 
> When changing the "Sent" folder of an account or identity, sometimes the
> icons also do not change (from yellow folder to/from blue stamp (on
> windows)).
> 
> If you move the mouse over the tree row, they are updated.

Do you still observe that? For me the blue icon toggles immediately.
Flags: needinfo?(bugzilla)
(In reply to :aceman from comment #8)

> Do you still observe that? For me the blue icon toggles immediately.

Sorry, this is now over 5 years - I dont have the original test environment (TB on Windows with KerioConnect IMAP server) any longer. However, in a quick test on OS X with TB 38.7.2, I could not reproduce the issue.
Closing referring comment 9
Status: NEW → RESOLVED
Closed: 5 years ago
Flags: needinfo?(bugzilla)
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.