Auto-complete popup for extensions doesn't allow scrolling

VERIFIED FIXED in 5.0.7

Status

P3
normal
VERIFIED FIXED
10 years ago
3 years ago

People

(Reporter: whimboo, Assigned: cesar)

Tracking

({access})

unspecified
5.0.7
access

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

10 years ago
When you wanna add new extensions to your collection and enter search terms like "extension" or "firefox" you will get a list of extensions which will cause a scroll bar to appear. When you use the arrow keys to move down the list it will only work for the first 5 entries. Further keypresses don't cause a scrolling. So you will not be able to select such an extension by keyboard. A mouse has to be used.

It should be keyboard accessible. :)

Comment 1

10 years ago
Not sure if the "major" severity is warranted, but I can confirm the bug: Scrolling is only possible with the mouse.

There's probably some JS missing (or broken?) here. We should compare it to the same feature on the admin pages. If it works there, we can reuse the code, if not, we should fix it there too.

Updated

10 years ago
Severity: major → normal
Keywords: access
Target Milestone: --- → 5.0.7
(Assignee)

Comment 2

10 years ago
Created attachment 383147 [details]
using the keyboard with latest plugin

(In reply to comment #1)
> There's probably some JS missing (or broken?) here. We should compare it to the
> same feature on the admin pages. If it works there, we can reuse the code, if
> not, we should fix it there too.

We seem to be using the same JS code for both pages. Digging in a little deeper, it looks like the next version of the auto-complete code somewhat fixes this problem for us (it looks like we are using http://plugins.jquery.com/project/autocompletex for our auto-complete plugin). I attached a screenshot looking at the last result. While it does scroll, it clips the icon a bit.

Updated

10 years ago
Assignee: nobody → cdolivei.bugzilla
Priority: -- → P3
(Assignee)

Comment 3

10 years ago
Committed in r28340. I checked the Admin's add-on manager, collections, and editor filter. All work as expected locally.
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Keywords: push-needed
Resolution: --- → FIXED
Verified FIXED; I filed 500296 as a spinoff (a limitation of the plugin, probably).
Status: RESOLVED → VERIFIED
Keywords: push-needed
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.