Last Comment Bug 497379 - make "Open Containing Folder" available during download already
: make "Open Containing Folder" available during download already
Status: RESOLVED FIXED
:
Product: SeaMonkey
Classification: Client Software
Component: Download & File Handling (show other bugs)
: Trunk
: All All
: -- enhancement (vote)
: seamonkey2.19
Assigned To: Christian Eyrich
:
Mentors:
Depends on: 497382
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-10 09:30 PDT by Rolf Bode-Meyer
Modified: 2013-02-25 06:09 PST (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
Patch with two small changes to solve this bug. (2.56 KB, patch)
2013-02-16 08:26 PST, Christian Eyrich
neil: review+
Details | Diff | Splinter Review
Removed comments. r=Neil (2.56 KB, patch)
2013-02-20 11:40 PST, Christian Eyrich
ch.ey: review+
Details | Diff | Splinter Review

Description Rolf Bode-Meyer 2009-06-10 09:30:12 PDT
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; de-AT; rv:1.9.1pre) Gecko/20090610 SeaMonkey/2.0b1pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1pre) Gecko/20090610 SeaMonkey/2.0b1pre

I'd find it a great help if "Open Containing Folder" in the DLM would already be available during download. That way I'd have to wait until download is finished for opening the folder.

Reproducible: Always
Comment 1 Daniel B. 2010-10-06 08:52:17 PDT
I agree.

SeaMonkey provides the feature of taking the user to the directory 
(folder) selected for the download.  (The user does not have to specify
the directory a second time (e.g., navigating to it in the file browser)
after specifying it when specifying where to save the downloaded file.

Unfortunately, SeaMonkey only provides that feature (enables the "Open
Containing Folder menu item) _after_ the download is complete, even 
though the user might want to go to that directory before the download 
is complete.

Remember than opening the downloaded file is not the only thing the
user might want to do with/in that download directory--the user might 
want to do something that does _not_ need to wait until the download 
is complete.

For example, after starting to download a file, I wanted to go (in 
the file browser) to the chosen download directory to create a
Windows shortcut to the web page that had the download link on it.  
Another example would be going to that directory to start cleaning 
out old versions of downloaded file while waiting for the current 
download to complete.
Comment 2 Jens Hatlak (:InvisibleSmiley) 2010-12-08 06:35:13 PST
Confirming RFE, though I'm not sure a patch would receive a positive review: After all the label reads "Open Containing Folder", and the download is only contained in that folder once it finishes (but maybe a temp file is stored there during download). Anyway, that nit might just need an additional label change then.
Comment 3 Christian Eyrich 2013-02-16 08:26:37 PST
Created attachment 714799 [details] [diff] [review]
Patch with two small changes to solve this bug.

Regarding comment 2, I don't see the need for changing the label because the files are indeed contained in the folder when the menu entries are available since the the code checks for exists() first.
Comment 4 Philip Chee 2013-02-17 08:53:04 PST
Comment on attachment 714799 [details] [diff] [review]
Patch with two small changes to solve this bug.

You need to set the review flag to someone specific. Otherwise nobody will notice that a review has been requested.
Comment 5 neil@parkwaycc.co.uk 2013-02-20 07:04:09 PST
Comment on attachment 714799 [details] [diff] [review]
Patch with two small changes to solve this bug.

r=me if you amend or remove the comment since it no longer applies.
Comment 6 Christian Eyrich 2013-02-20 11:40:11 PST
Created attachment 716150 [details] [diff] [review]
Removed comments. r=Neil

Removed comments completely because it should be obvious why Open isn't available for a running download.
Comment 7 Philip Chee 2013-02-21 01:28:55 PST
Comment on attachment 716150 [details] [diff] [review]
Removed comments. r=Neil

Thanks. Do you require assistance to get this patch checked-in to the tree? Or do you have commit rights?
Comment 8 Christian Eyrich 2013-02-21 09:39:00 PST
No, I don't have commit rights. Would be great if you would check it in for me.
Comment 9 Robert Kaiser 2013-02-24 14:31:12 PST
Comment on attachment 716150 [details] [diff] [review]
Removed comments. r=Neil

Review of attachment 716150 [details] [diff] [review]:
-----------------------------------------------------------------

I'm not a fan of doing things this way at all, but I gave up ownership of download manager a long time ago.
Comment 10 Philip Chee 2013-02-25 06:09:44 PST
Pushed to comm-central:
http://hg.mozilla.org/comm-central/rev/05066341d74c

Thank you Christian!

Note You need to log in before you can comment on or make changes to this bug.