crash while recalculating frecency

VERIFIED DUPLICATE of bug 493538

Status

()

Toolkit
Places
VERIFIED DUPLICATE of bug 493538
9 years ago
9 years ago

People

(Reporter: dietrich, Unassigned)

Tracking

({crash})

Trunk
x86
Windows XP
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

9 years ago
see URL
(Reporter)

Comment 1

9 years ago
windows only, 29 crashes on b4 and newer in the last week:

http://is.gd/XZpn
All since June 3rd, even. Maybe

bug 494370 - Better query for mDBGetItemProperties

or 

bug 494371 - Get itemType only once per itemAdded notification
a previous instance of a similar crash has been addressed in bug 493538.
in such a case it was due to GetDBInvalidFrecencies, that was not taking in count column number differences between real tables and temp tables.

Comment 4

9 years ago
The line seems to be:
  nsresult rv = aStatement->BindInt32Parameter(0, aCount);

So yeah this sounds familiar where aStatement (GetDBInvalidFrecencies()) is returning null because it fails to create the statement.
Actually looking at link in comment 1, i don't see any crash after 19 May build. so this is probably simply a dupe since that crash has been fixed from 20 May build.
FWIW, this happened on a branch-nightly build from 05/15 (built from changeset a6445e2e8691) so Marco's probably right.
Yeah, this has been fixed. Sorry for the bad report, folks!
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → INVALID

Updated

9 years ago
Resolution: INVALID → DUPLICATE
Duplicate of bug: 493538

Updated

9 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.