Linux does not prompt to Save & Quit when OS restarted

VERIFIED DUPLICATE of bug 449548

Status

()

Firefox
Session Restore
VERIFIED DUPLICATE of bug 449548
9 years ago
9 years ago

People

(Reporter: ashughes, Unassigned)

Tracking

3.5 Branch
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

9 years ago
Mozilla/5.0 (X11; U; Linux i686; en-US; rv; 1.9.1pre)
Gecko/20090610 Shiretoko/3.5pre

In accordance with the test case (see URL), I do not get prompted to Save & Quit.  However my session is restored.  I am prompted on Mac and Windows.  The experience should be the same across all platforms.

STR:
   1. Start Firefox with a new profile
   2. Open the Preferences dialog
   3. On the Main page, under Startup, make sure "When Firefox starts" is set
to "Show my home page"
   4. Close the Preferences dialog
   5. Have three tabs open (google.com, cnn.com, digg.com)
   6. Restart your Operating System
   7. Select "Save and Quit" if prompted to do so.
   8. Start Firefox when your operating system restarts

RESULT:
Step 7 never occurs.  The OS just restarts.  My session is restored when I restart Firefox.

EXPECTED:
I should be prompted to Save & Quit.

NOTE: I only see this on Linux.  This does not happen on Windows and Mac builds.

Comment 1

9 years ago
Yeah, there's something wonky going on with Firefox and Gnome session management (and maybe other desktops?). That should be bug 449548.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 449548
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.