bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

Thunderbird hangs on RSS feed

RESOLVED WORKSFORME

Status

MailNews Core
Feed Reader
RESOLVED WORKSFORME
9 years ago
9 years ago

People

(Reporter: Louis Kruger, Unassigned)

Tracking

({hang})

1.8 Branch
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1b4) Gecko/20090423 Firefox/3.5b4
Build Identifier: version 2.0.0.21 (20090502)

I try to add the feed at "http://marketplace.publicradio.org/RSS/whiteboard_podcast.xml".  Thunderbird will hang forever at "downloading articles".  The same feed works with other RSS software, including Firefox.

I waited 30 minutes to make sure it wasn't just being slow.

Reproducible: Always

Steps to Reproduce:
1.  Add affected feed to folder using "Manage Subscriptions" dialog.
2.
3.
Actual Results:  
Thunderbird hangs.  The operation must be aborted.

Expected Results:  
The feed is added to my subscription list and the articles are downloaded.

A second affected feed is:  http://marketplace.publicradio.org/RSS/moneyclip_podcast.xml
This is WFM on Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1pre) Gecko/20090609 Shredder/3.0b3pre
Component: General → Feed Reader
Keywords: hang
Product: Thunderbird → MailNews Core
QA Contact: general → feed.reader
Version: unspecified → 1.8 Branch
(Reporter)

Comment 2

9 years ago
I spoke too soon above, it's not working for me with Firefox either.  I can add the LiveBookmark, but the folder is empty.  The version string is Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1b4) Gecko/20090423 Firefox/3.5b4

It does work in other RSS software though, including Juice and Google Reader.
(Reporter)

Comment 3

9 years ago
I just downloaded Thunderbird 3.0b2 to test, and my result matches Ludovic: it does work in that version.
Also going back to 2.0 after subscribing in 3.0b2, the feed is still there and the articles work and it doesn't hang when I try to update it.  When they post a new podcast I'll report back whether it updated correctly in 2.0.  So far it looks like it's just the initial subscribe that is bugged in Thunderbird 2.0

But it's still not working in Firefox 3.5b4 either.
(In reply to comment #3)
 
> But it's still not working in Firefox 3.5b4 either.

Feel free to open a different bug for firefox.

I'm going to close this a WFM, because it works in TB3. TB2 only get updated security wise. Feel free to reopen if you think I'm not doing the right thing.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.