Crash [@ nsGeolocationRequest::GetRequestingURI][@ XPCWrappedNative::CallMethod]

RESOLVED WORKSFORME

Status

()

Core
Geolocation
--
critical
RESOLVED WORKSFORME
9 years ago
7 years ago

People

(Reporter: Martijn Wargers (dead), Unassigned)

Tracking

({crash, testcase})

Trunk
x86
Windows XP
crash, testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

Attachments

(1 attachment)

(Reporter)

Description

9 years ago
Created attachment 382706 [details]
testcase

See testcase, which crashes when you open it locally on your computer, then on the infobar, check the "Remember for this site" checkbox and then keep on clicking on the "Share Location" button.

http://crash-stats.mozilla.com/report/index/00876b6e-2b9b-4587-892a-19f2c2090611?p=1
0  	xul.dll  	ns_if_addref<nsIDirIndexListener*>  	 obj-firefox/dist/include/nsISupportsUtils.h:114
1 	xul.dll 	nsGeolocationRequest::GetRequestingURI 	dom/src/geolocation/nsGeolocation.cpp:218
2 	xul.dll 	NS_InvokeByIndex_P 	xpcom/reflect/xptcall/src/md/win32/xptcinvoke.cpp:101
3 	xul.dll 	XPCWrappedNative::CallMethod 	js/src/xpconnect/src/xpcwrappednative.cpp:2478

http://crash-stats.mozilla.com/report/index/a4bcfc07-4c27-4c7a-8dd0-002f12090611?p=1
0  	xul.dll  	xul.dll@0x92bea9  	
1 	xul.dll 	XPCWrappedNative::CallMethod 	js/src/xpconnect/src/xpcwrappednative.cpp:2478
2 	xul.dll 	XPC_WN_GetterSetter 	js/src/xpconnect/src/xpcwrappednativejsops.cpp:1622
3 	js3250.dll 	js_Invoke 	js/src/jsinterp.cpp:1386
4 	js3250.dll 	js_InternalInvoke 	js/src/jsinterp.cpp:1447
5 	js3250.dll 	js_Interpret 	js/src/jsinterp.cpp:4436
6 	js3250.dll 	js_Invoke 	js/src/jsinterp.cpp:1394
7 	js3250.dll 	js_InternalInvoke 	js/src/jsinterp.cpp:1447
8 	js3250.dll 	JS_CallFunctionValue 	js/src/jsapi.cpp:5193
9 	xul.dll 	nsJSContext::CallEventHandler 	dom/base/nsJSEnvironment.cpp:2035
10 	xul.dll 	nsJSEventListener::HandleEvent 	dom/src/events/nsJSEventListener.cpp:247
11 	xul.dll 	nsEventListenerManager::HandleEventSubType 	content/events/src/nsEventListenerManager.cpp:1087
12 	xul.dll 	nsEventListenerManager::HandleEvent 	content/events/src/nsEventListenerManager.cpp:1187
13 	xul.dll 	nsEventTargetChainItem::HandleEventTargetChain 	content/events/src/nsEventDispatcher.cpp:315
etc..

Also, I'm seeing this javascript error in the javascript console:
Error: uncaught exception: [Exception... "Component returned failure code: 0x80004003 (NS_ERROR_INVALID_POINTER) [nsIPermissionManager.add]"  nsresult: "0x80004003 (NS_ERROR_INVALID_POINTER)"  location: "JS frame :: file:///C:/Documents%20and%20Settings/mw/Bureaublad/moz/firefox20090610/components/nsBrowserGlue.js :: setPagePermission :: line 998"  data: no]
This is very likely happening because the permission manager can't handle local file urls (I've had my problems with that more often).
(Reporter)

Comment 1

9 years ago
The crash only seems to happen locally on the computer, e.g. with  file:// URIs, not on any website, afaict.

Comment 2

9 years ago
Martijn, this is not crashing for me.  can you reproduce still?
(Reporter)

Updated

9 years ago
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WORKSFORME
(Assignee)

Updated

7 years ago
Crash Signature: [@ nsGeolocationRequest::GetRequestingURI] [@ XPCWrappedNative::CallMethod]
You need to log in before you can comment on or make changes to this bug.