If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Error pop up not appearing when email address is invalid

RESOLVED FIXED in Thunderbird 3.0b3

Status

Thunderbird
Message Compose Window
--
major
RESOLVED FIXED
8 years ago
8 years ago

People

(Reporter: Peter B, Assigned: Magnus Melin)

Tracking

({regression})

Trunk
Thunderbird 3.0b3
regression
Bug Flags:
blocking-thunderbird3 +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

5.47 KB, patch
Magnus Melin
: review+
clarkbw
: ui-review+
Details | Diff | Splinter Review
(Reporter)

Description

8 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 5.1; .NET CLR 1.1.4322; .NET CLR 2.0.50727)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1pre) Gecko/20090607 Shredder/3.0b3pre

If the email address is invalid such as test.test.com (no @) or contains unrecognised characters such as "yumi iwase(岩瀬 由美) <yumi@japan.jp>" where the strange characters are in the Japanese character set, then a popup error should occur when you try to send the mail.

With the current Shredder no error message appears and if you believe you have a valid format you can keep clicking on Send but nothing happens

Regards
Peter

Reproducible: Always

Steps to Reproduce:
1. Reply to email that has unrecognised characters in the senders name
or
2.enter an email address in an invalid format shuch as test.test.com (no @)
3.
Actual Results:  
Mail not sent and no error message (pop up)

Expected Results:  
should have produced a pop up error message in the format: (this one is Italian but you get the idea - from Thunderbird/3.0b2)
test.test.com non è un indirizzo e-mail valido in quanto non è nella forma utente@server. Deve essere corretto prima di inviare l'e-mail.
Confirming : Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1pre) Gecko/20090618 Shredder/3.0b3pre
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: blocking-thunderbird3?
Keywords: polish
OS: Windows XP → All
Hardware: x86 → All
Version: unspecified → Trunk
(Assignee)

Comment 2

8 years ago
How are the addresses invalid?
Addresses don't have to have @ (for local delivery), and japanese characters in the name is allowed, no?

Getting all addresses verified to be correct is very very hard so we don't try.
(Reporter)

Comment 3

8 years ago
It is not that the address is verified to be correct it is just that it is not seen to be in a valid format. 

You can test by copying and pasting the japan.jp address above and try to send an email. Do not worry it is not a real address.

With TB 3 beta 1 or 2 you get a popup saying that the address is not in the correct format. In Shredder/3.0b3pre nothing at all happens. 

If you then remove the strange characters from the user name, that is to say "(岩瀬 由美) ", shredder will (attempt to) send the email.

With the real version of this address that is what I have to do to send the email even in previous versions which raises the point that any characters , japanese, greek, whatever, should be allowed in the recipient name part of the email address.

I hope that is all clear,

Regards
(Assignee)

Comment 4

8 years ago
Ok, in the (native) console i get

*** Failed to get string sendMsgTitle in bundle: chrome://messenger/locale/messengercompose/composeMsgs.properties
An error occurred executing the cmd_sendButton command
[Exception... "Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [nsIStringBundle.GetStringFromName]"  nsresult: "0x80004005 (NS_ERROR_FAILURE)"  location: "JS frame :: XStringBundle :: getString :: line 17"  data: no]

Regression from bug 367698. 
http://hg.mozilla.org/comm-central/rev/7b28a6f2c5af

The comment in the properties threw us of...
Assignee: nobody → mkmelin+mozilla
Blocks: 367698
Status: NEW → ASSIGNED
Flags: blocking-thunderbird3? → blocking-thunderbird3+
Keywords: polish → regression
Target Milestone: --- → Thunderbird 3.0b3
(Assignee)

Comment 5

8 years ago
Created attachment 385152 [details] [diff] [review]
proposed fix

Adding back (improved versions of) the strings, and using a specific version for each different kind of dialog.
Attachment #385152 - Flags: ui-review?(clarkbw)
Attachment #385152 - Flags: review?(bugzilla)
Duplicate of this bug: 499723
from Bug 499723 comment 0

 +++ This bug was initially created as a clone of Bug #399329 +++
 bug 399329 Comment 5 
 b) when autocomplete is off, thunderbird is not issuing a warning message (but
 seammonkey does [1]) - i.e. Send fails silently which is not good, except for
 blinking red cursor indicating incomplete address
 [1] SM issues 
  " " is not a valid e-mail address because it is not of the form user@host. You
  must correct it before sending the e-mail.

 bug 399329 Comment 6 From Marco Zehe (:MarcoZ) 
 This is indeed an accessibility issue in many ways:
 a) Screen readers won't notice and wonder why sending the message fails on
 them.
 b) color-blind people may have trouble seeing that the blinking cursor is red.
Severity: normal → major
Keywords: access
Attachment #385152 - Flags: review?(bugzilla) → review+
Comment on attachment 385152 [details] [diff] [review]
proposed fix

>   {
>     var bundle = document.getElementById("bundle_composeMsgs");
>-    var errorTitle = bundle.getString("sendMsgTitle");
>+    var errorTitle = bundle.getString("addressInvalidTitle");
>     var errorMsg = bundle.getFormattedString("addressInvalid", [invalidStr], 1);
>     if (gPromptService)
>       gPromptService.alert(window, errorTitle, errorMsg);

Let's drop the errorTitle and errorMsg intermediate variables whilst we're here - we don't need them.

r=Standard8 with that change.
Whiteboard: [needs ui-review clarkbw][needs updated patch]
(Assignee)

Comment 9

8 years ago
Created attachment 385356 [details] [diff] [review]
proposed fix, v2

Carrying fwd r=standard8
Attachment #385152 - Attachment is obsolete: true
Attachment #385356 - Flags: ui-review?(clarkbw)
Attachment #385356 - Flags: review+
Attachment #385152 - Flags: ui-review?(clarkbw)
(Assignee)

Updated

8 years ago
Whiteboard: [needs ui-review clarkbw][needs updated patch] → [needs ui-review clarkbw]
Comment on attachment 385356 [details] [diff] [review]
proposed fix, v2

am i giving a plus to adding back a dialog?  i guess it's better than the silent fail we have now. :)

Thanks for doing this!
Attachment #385356 - Flags: ui-review?(clarkbw) → ui-review+
(Reporter)

Comment 11

8 years ago
I agree that the 'pop up' dialog is definitely better than the silent fail.

Please also look at the issue of the Japanese characters causing a fail. I have not tested but this may have something to do with the fact that outgoing email addresses are automatically saved. Unknown characters should not cause a problem if they are in the user name part of the email address.

To encapsulate what I have written before on this:

If the email address contains unrecognised characters such as "yumi iwase(岩瀬 由美) <yumi@japan.jp>" where the
strange characters are in the Japanese character set...................

You can test by copying and pasting the japan.jp address above and try to send an email. Do not worry it is not a real address.

I have done a test and it seems the '(' is the problem. If the '(' is removed the email can go. I suspect that this character is something else in the Japanese character set but I do not know.

Thanks to all for the work on this.
(Assignee)

Comment 12

8 years ago
changeset:   2964:23e14af0a02b
http://hg.mozilla.org/comm-central/rev/23e14af0a02b

->FIXED
Status: ASSIGNED → RESOLVED
Last Resolved: 8 years ago
Keywords: access
Resolution: --- → FIXED
Whiteboard: [needs ui-review clarkbw]
You need to log in before you can comment on or make changes to this bug.