Shiretoko renders some images with wrong colors

RESOLVED DUPLICATE of bug 497363

Status

()

defect
--
major
RESOLVED DUPLICATE of bug 497363
10 years ago
10 years ago

People

(Reporter: thought.engineer, Unassigned)

Tracking

1.9.1 Branch
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

()

Attachments

(1 attachment)

Reporter

Description

10 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.1pre) Gecko/20090610 Ubuntu/9.04 (jaunty) Shiretoko/3.5pre
Build Identifier: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.1pre) Gecko/20090610 Ubuntu/9.04 (jaunty) Shiretoko/3.5pre

Some images render with the wrong colors. It happens with some .jpg images and some .png images. I have noticed this several times.

Reproducible: Always

Steps to Reproduce:
1.Go to http://www.alwaysinnovating.com/touchbook/
2.See purpleish background color
3.Weep
Actual Results:  
The background image renders as a purpleish color.

Expected Results:  
Expected to see a red background. The background is actually a redish color. It renders properly in FF 3.0.10.

This is from the Mozilla Daily Builds PPA from Launchpad. See attached screen shot for comparison. I can attach other system info if that will help, or if it will help determine that it is a problem with my desktop setup.

Comment 2

10 years ago
Try this:
1. put about:config into the address bar, enter, click through any warning
2. paste gfx.color_management.mode into the filter box
3. double-click that pref to edit the value to 0
4. restart Firefox and see the photos look normal again
5(i) investigate the faulty color correction profile your monitor has to change it, or
5(ii) throw your monitor out the window.
Reporter

Comment 3

10 years ago
Mardeg, that fixed it. Please elaborate more on this:

5(i) investigate the faulty color correction profile your monitor has to change
it, or
5(ii) throw your monitor out the window.

Is this something I should report to Ubuntu? If so, to which package?

Updated

10 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Component: General → GFX: Color Management
Product: Firefox → Core
QA Contact: general → color-management
Resolution: --- → DUPLICATE
Version: unspecified → 1.9.1 Branch
Duplicate of bug: 460629

Updated

10 years ago
Duplicate of bug: 497363
You need to log in before you can comment on or make changes to this bug.