Opening XUL files crashes Mozilla

VERIFIED DUPLICATE of bug 49659

Status

()

P3
major
VERIFIED DUPLICATE of bug 49659
18 years ago
18 years ago

People

(Reporter: kerz, Assigned: hyatt)

Tracking

({crash})

Trunk
x86
Windows 2000
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
From Bugzilla Helper:
User-Agent: Mozilla/4.75 [en] (Windows NT 5.0; U)
BuildID:    082108

I can reproduce this in a number of ways.  File>Open>Any XULFILE.xul, 
urlbar>XULFILE.xul, Drag and Drop any XULFILE.xul, set a shortcut to mozilla.exe 

file:///c:/path/to/any/XULFILE.xul will all crash me.
							

Reproducible: Always
Steps to Reproduce:
1. Open an XUL file from any of the steps above
2. Crash							

Actual Results:  I crashed				

Expected Results:  It shouldn't crash							

Please fix this bug.

Comment 1

18 years ago
Removing BAD.  This seems like one of those rare good bugs to me.

sending to networking for a first look...
Assignee: asa → gagan
Component: Browser-General → Networking
QA Contact: doronr → tever
Summary: BAD: Opening XUL files crashes Mozilla → Opening XUL files crashes Mozilla

Comment 2

18 years ago
I think it is crashing in nschromeRegistry

Comment 3

18 years ago
Could someone please post a stack trace here. Based on comments above this might
be related to hyatt's checkins... ? 
Assignee: gagan → hyatt

Comment 4

18 years ago
Here is a talkback trace for a mozilla talkback build 2000082109 (my builds are 
not up-to-date).

Dave: note: this crash is in this morning's builds, prior to mstolz' checkin
for allowing access to chrome:// stylesheets. 

nsChromeRegistry::GetStyleSheets 
[d:\builds\seamonkey\mozilla\rdf\chrome\src\nsChromeRegistry.cpp, line 771] 
nsXULDocument::EndLoad 
[d:\builds\seamonkey\mozilla\rdf\content\src\nsXULDocument.cpp, line 1544] 
XULContentSinkImpl::DidBuildModel 
[d:\builds\seamonkey\mozilla\rdf\content\src\nsXULContentSink.cpp, line 556] 
CWellFormedDTD::DidBuildModel 
[d:\builds\seamonkey\mozilla\htmlparser\src\nsWellFormedDTD.cpp, line 315] 
nsParser::DidBuildModel 
[d:\builds\seamonkey\mozilla\htmlparser\src\nsParser.cpp, line 1394] 
nsParser::ResumeParse [d:\builds\seamonkey\mozilla\htmlparser\src\nsParser.cpp, 
line 1914] 
nsParser::EnableParser [d:\builds\seamonkey\mozilla\htmlparser\src\nsParser.cpp, 
line 1497] 
CSSLoaderImpl::Cleanup 
[d:\builds\seamonkey\mozilla\layout\html\style\src\nsCSSLoader.cpp, line 710] 
CSSLoaderImpl::SheetComplete 
[d:\builds\seamonkey\mozilla\layout\html\style\src\nsCSSLoader.cpp, line 833] 
CSSLoaderImpl::Cleanup 
[d:\builds\seamonkey\mozilla\layout\html\style\src\nsCSSLoader.cpp, line 691] 
CSSLoaderImpl::SheetComplete 
[d:\builds\seamonkey\mozilla\layout\html\style\src\nsCSSLoader.cpp, line 833] 
CSSLoaderImpl::ParseSheet 
[d:\builds\seamonkey\mozilla\layout\html\style\src\nsCSSLoader.cpp, line 868] 
CSSLoaderImpl::DidLoadStyle 
[d:\builds\seamonkey\mozilla\layout\html\style\src\nsCSSLoader.cpp, line 904] 
SheetLoadData::OnStreamComplete 
[d:\builds\seamonkey\mozilla\layout\html\style\src\nsCSSLoader.cpp, line 648] 
nsStreamLoader::OnStopRequest 
[d:\builds\seamonkey\mozilla\netwerk\base\src\nsStreamLoader.cpp, line 123] 
nsResChannel::EndRequest 
[d:\builds\seamonkey\mozilla\netwerk\protocol\res\src\nsResChannel.cpp, line 
730] 
nsResChannel::OnStopRequest 
[d:\builds\seamonkey\mozilla\netwerk\protocol\res\src\nsResChannel.cpp, line 
715] 
nsFileChannel::OnStopRequest 
[d:\builds\seamonkey\mozilla\netwerk\protocol\file\src\nsFileChannel.cpp, line 
649] 
nsOnStopRequestEvent::HandleEvent 
[d:\builds\seamonkey\mozilla\netwerk\base\src\nsAsyncStreamListener.cpp, line 
302] 
nsStreamListenerEvent::HandlePLEvent 
[d:\builds\seamonkey\mozilla\netwerk\base\src\nsAsyncStreamListener.cpp, line 
106] 
PL_HandleEvent [d:\builds\seamonkey\mozilla\xpcom\threads\plevent.c, line 588] 
_md_EventReceiverProc [d:\builds\seamonkey\mozilla\xpcom\threads\plevent.c, line 
1045] 
USER32.DLL + 0x3eb0 (0x77e13eb0) 
USER32.DLL + 0x401a (0x77e1401a) 
USER32.DLL + 0x92da (0x77e192da) 
nsAppShellService::Run 
[d:\builds\seamonkey\mozilla\xpfe\appshell\src\nsAppShellService.cpp, line 379] 
main1 [d:\builds\seamonkey\mozilla\xpfe\bootstrap\nsAppRunner.cpp, line 950] 
main [d:\builds\seamonkey\mozilla\xpfe\bootstrap\nsAppRunner.cpp, line 1125] 
WinMain [d:\builds\seamonkey\mozilla\xpfe\bootstrap\nsAppRunner.cpp, line 1141] 
WinMainCRTStartup() 
KERNEL32.DLL + 0x7903 (0x77e87903) 

cc: warren, as he was changing the code in that area (although just to add 
error-checking). 

Comment 5

18 years ago
Adding crash keyword.
Keywords: crash

Comment 6

18 years ago
I think warren fixed this one too with his checkin for bug 49659 (same stack,
same location in the file where he added in an additional check on the rv
of GetDynamicInfo). The steps to reproduce that other bug were slightly 
different, but also involved opening a file:// .xul file. Marking this one as
a duplicate -- I'm sure we'll hear if this is not indeed fixed :-\

*** This bug has been marked as a duplicate of 49659 ***
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 7

18 years ago
verified dup
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.