audio tag with controls,width=0, height=0 gives visible controls, video tag set the same doesn't.

RESOLVED INVALID

Status

()

Toolkit
Video/Audio Controls
RESOLVED INVALID
9 years ago
2 years ago

People

(Reporter: Gregory Maxwell, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.1pre) Gecko/20090606 Shiretoko/3.5pre
Build Identifier: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.1pre) Gecko/20090606 Shiretoko/3.5pre

The Audio and video tags playing the same file with the same settings behave differently. 

Example:
http://myrandomnode.dyndns.org:8080/~gmaxwell/firefox/test4.html



Reproducible: Always

Steps to Reproduce:
1. Use audio tag with controls and zero width/height
2.
3.
Actual Results:  
get controls

Expected Results:  
no controls (probably?) ; or if it does get controls then video should too

Updated

9 years ago
Version: unspecified → 1.9.1 Branch

Comment 1

9 years ago
Could you please attach a reduced testcase to this bug so it is on file incase that test disappears?
I don't think there's anything special about the particular testcase.

<audio src="..." height="0" width="0" controls>
vs.
<video src="..." height="0" width="0" controls>

I'd guess this a combination of how the XUL bits determine their width, and the timing of when when we decide to show or hide them, but I haven't had a chance to look at it in detail yet.
Status: UNCONFIRMED → NEW
Ever confirmed: true
This is because that audio element does not have width and height attributes. If you want to set width and height of audio element, you can use CSS style width and height like this:

<audio src="..." style="width: 0px; height: 0px"/>
Component: Video/Audio → Video/Audio Controls
Product: Core → Toolkit
QA Contact: video.audio → video.audio
Version: 1.9.1 Branch → unspecified

Comment 4

8 years ago
http://www.whatwg.org/specs/web-apps/current-work/multipage/video.html#audio

As long as the spec doesn't allow this attributes for <audio>, this bug is INVALID.

A different bug is: It doesn't work with CSS width:0; height:0; as well.
(In reply to comment #4)
> A different bug is: It doesn't work with CSS width:0; height:0; as well.

I filed a similar bug a few minutes ago:  bug 672037.
Resolving invalid per comment #4.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.