release extension update (1.2.1) for Thunderbird regression

RESOLVED FIXED

Status

Mozilla Labs Graveyard
Personas Plus
RESOLVED FIXED
9 years ago
a year ago

People

(Reporter: myk, Assigned: myk)

Tracking

Details

(Assignee)

Description

9 years ago
Personas 1.2 doesn't work on Thunderbird because it assumes the presence of FUEL.  We should release a minor update to 1.2 that fixes that problem.
(Assignee)

Comment 1

9 years ago
I've applied the fix in bug 497564 to the 1.2 branch and built a release candidate for 1.2.1:

http://people.mozilla.com/~cbeard/personas/dist/personas-v1.2.1rc1.xpi
(Assignee)

Comment 2

9 years ago
I've pushed a second RC to incorporate an additional localization (hu-HU) that recently landed:

https://people.mozilla.com/~cbeard/personas/dist/personas-v1.2.1rc2.xpi

Note: for the first time in Personas history, this is a true RC in that it is code-complete (i.e. no changes are necessary to release this as 1.2.1).  In the past, we've included "rc[n]" in the version string inside the install.rdf file for release candidates.

We originally did this because AMO requires it (it doesn't allow you to upload two versions of the extension with the same version string).  But now that we don't distribute RCs via AMO, because we only distribute release builds there, we don't have to do this.

So barring any unforeseen complications, this is the exact build that will become Personas 1.2.1.
For me, this RC2 fixed the bug in Thunderbird.
Everything went back to normal.

Thanks ;)
(Assignee)

Comment 4

9 years ago
I just pushed a third release candidate to fix a regression from the checkin for bug 497564 that didn't manifest itself in my initial testing:

https://people.mozilla.com/~cbeard/personas/dist/personas-v1.2.1rc3.xpi
(Assignee)

Comment 5

9 years ago
Flore discovered bug 498284 while testing this weekend.  It breaks the new feature introduced in version 1.2, so it should be considered a high priority blocker for the 1.2.1 release.

Fortunately, the fix was simple, and I've spun a new RC that includes it:

http://people.mozilla.com/~cbeard/personas/dist/personas-v1.2.1rc4.xpi
(Assignee)

Updated

8 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
Product: Mozilla Labs → Mozilla Labs Graveyard
You need to log in before you can comment on or make changes to this bug.