XHTML 1.0 Trans - H2 within DT is placed outside of DT within the DOM

RESOLVED DUPLICATE of bug 324875

Status

()

Firefox
General
RESOLVED DUPLICATE of bug 324875
9 years ago
9 years ago

People

(Reporter: Kory Sutherland, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.0.10) Gecko/2009042316 Firefox/3.0.10 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.0.10) Gecko/2009042316 Firefox/3.0.10 (.NET CLR 3.5.30729)

Nesting an <H2> object within the <DT> object of a <DL> causes Firefox to restructure the DOM, placing the <H2> object outside of the <DT> object, even though there is no change in the source code.

For example, when Firefox encounters the following code...

<dl>
<dt><h2>Definition Term</h2></dt>
<dd>Definition elaboration</dd>
</dl>

... it restructures the DOM and renders it as follows:

<dl>
<dt></dt>
<h2>Definition Term</h2>
<dd>Definition Explanation</dd>
</dl>

Reproducible: Always

Steps to Reproduce:
1. Create a Definition List <DL>
2. Nest <DT></DT> tags within the <DL></DL> tags
3. Nest <H2>Foo</H2> tags within the <DT></DT> tags
Actual Results:  
The <H2> object is placed outside of the <DT> object

Expected Results:  
The <H2> object should be placed (and rendered) within the <DT> object

According to the W3C XHTML 1.0 Transitional spec, this is not acceptable markup. It, however, would be nice if it worked anyhow.

Updated

9 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 324875
You need to log in before you can comment on or make changes to this bug.