If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

"ASSERTION: Should delay load event while loading in document"

NEW
Unassigned

Status

()

Core
Audio/Video: Playback
8 years ago
2 years ago

People

(Reporter: Jesse Ruderman, Unassigned)

Tracking

(Blocks: 1 bug, {assertion, testcase})

Trunk
x86
Mac OS X
assertion, testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

363 bytes, application/xhtml+xml
Details
388 bytes, text/html
Details
(Reporter)

Description

8 years ago
Created attachment 382860 [details]
testcase

###!!! ASSERTION: Should only iterate over direct children: 'startContainer == thisDomNode', file /Users/jruderman/central/content/html/content/src/nsHTMLMediaElement.cpp, line 1646

###!!! ASSERTION: Should delay load event while loading in document: '!IsInDoc() || mDelayingLoadEvent', file /Users/jruderman/central/content/html/content/src/nsHTMLMediaElement.cpp, line 493

The first assertion is covered by bug 495546.
(Reporter)

Comment 1

4 years ago
Still happens on trunk after the change in e79927f90d0b (!?)

###!!! ASSERTION: Should delay load event (if in document) during load: 'mDelayingLoadEvent', file content/html/content/src/HTMLMediaElement.cpp, line 855
(Reporter)

Comment 2

2 years ago
Created attachment 8600250 [details]
testcase 2
Component: Audio/Video → Audio/Video: Playback
These testcases try to hit youtube in automation, which then causes non-local network connection crashes. Any way to adjust them to not hit the outside network?
https://treeherder.mozilla.org/logviewer.html#?job_id=12960170&repo=try
Flags: needinfo?(jruderman)
Nevermind, it was pollution from the previous test. That said, the first testcase still hits the "Should delay load event while loading in document" assertion this was filed for.
Flags: needinfo?(jruderman)
You need to log in before you can comment on or make changes to this bug.