Title attribute is ignored when form element is disabled

RESOLVED WORKSFORME

Status

()

defect
RESOLVED WORKSFORME
10 years ago
4 years ago

People

(Reporter: andre, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

()

Reporter

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.9.0.10) Gecko/2009042316 Firefox/3.0.10 FirePHP/0.3
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.9.0.10) Gecko/2009042316 Firefox/3.0.10 FirePHP/0.3

When a form element is disabled but has a title attribute, the title is not shown in a tooltip.

Furthermore, when the form element is in another element which has a title, the title of that element is not shown as well.

Reproducible: Always

Steps to Reproduce:
1. Browse to the given demo URL
2. Hover the mouse over the disabled form elements
3. Hover the mouse over the enabled form elements
4. Hover the mouse over "some text"
Actual Results:  
Nothing happens when you hover over the disabled form elements

Expected Results:  
A tooltip with "blah" in it should be displayed, as it is when you hover over the enabled elements

I am not sure whether, according to the standard, a disabled form element should have a title tooltip but I guess it should. Nevertheless the title of the surrounding element should definitely be shown, and since there is no workaround I set serverity to "normal".
Component: General → Layout: Form Controls
Product: Firefox → Core
QA Contact: general → layout.form-controls
Bug 218093 explains what's going on here.
Status: UNCONFIRMED → NEW
Component: Layout: Form Controls → DOM: Events
Depends on: 218093
Ever confirmed: true
QA Contact: layout.form-controls → events
Duplicate of this bug: 574147
See Also: → 1220048
See Also: 1220048
Disabled elements *do* show the tooltip in Firefox 41.0.2. So it seems this got fixed earlier.

Sebastian
Status: NEW → RESOLVED
Closed: 4 years ago
OS: Windows XP → All
Hardware: x86 → All
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.