Closed Bug 497826 Opened 12 years ago Closed 12 years ago

_PLATFORM_DEFAULT_TOOLKIT of WinCE should be 'cairo-windows' instead of 'windows'

Categories

(Firefox Build System :: General, defect)

All
Windows CE
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED
mozilla1.9.2a1

People

(Reporter: m_kato, Assigned: m_kato)

References

()

Details

Attachments

(2 files)

Attached patch patch v1Splinter Review
The default value of _PLATFORM_DEFAULT_TOOLKIT of WinCE is invalid.  it should be 'cairo-windows' instead of 'windows'.   On build instruction of WinCE (https://wiki.mozilla.org/Mobile/Build/Windows_Mobile_BuildingIt), it is defined as it.
Attachment #382929 - Flags: review?(ted.mielczarek)
Comment on attachment 382929 [details] [diff] [review]
patch v1

Good call. Those mozconfigs are still depressingly large. We should get more of the defaults in configure set correctly for WinCE builds.
Attachment #382929 - Flags: review?(ted.mielczarek) → review+
landed
http://hg.mozilla.org/mozilla-central/rev/c6a2d1342334
Status: NEW → RESOLVED
Closed: 12 years ago
Resolution: --- → FIXED
Flags: in-testsuite-
Target Milestone: --- → mozilla1.9.2a1
Attachment #427647 - Flags: review?(bugspam.Callek) → review+
Comment on attachment 427647 [details] [diff] [review]
(Bv1) Copy it to comm-central
[Checkin: Comment 4]


http://hg.mozilla.org/comm-central/rev/8b558e5b1cb0
Attachment #427647 - Attachment description: (Bv1) Copy it to comm-central → (Bv1) Copy it to comm-central [Checkin: Comment 4]
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.