drag and drop of tabs lost a lot of functionality

RESOLVED DUPLICATE of bug 490841

Status

()

Firefox
Tabbed Browser
--
major
RESOLVED DUPLICATE of bug 490841
9 years ago
9 years ago

People

(Reporter: Martin Stružský, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; cs; rv:1.9.1b99) Gecko/20090605 Firefox/3.5b99 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; cs; rv:1.9.1b99) Gecko/20090605 Firefox/3.5b99 (.NET CLR 3.5.30729)

Reposting bug 490841, whose status was changed to uncofirmed and nobody cares about it, although it is a major drawback and should be fixed. Sorry for duplicate, but I don't know what else to do...

DESCRIPTION: In Firefox 3.0 it was possible to drag and drop any tab to a desktop/text field to create a link, then the feature got lost in 3.1b1 (dragging anywhere outside caused a new window to open) to be restored in 3.1b2 and remain in 3.1b3, and finally, now with 3.5b4, it's gone again. 

Reproducible: Always

------- Comment #1 From Ria Klaassen 2009-04-30  -------

I tested this with the latest trunk build on Windows XP and indeed, it creates
a new window (Bug 475066).

------- Comment #2 From Martin Stružský 2009-06-04 06:36:06 -------

Well, Ria Klaassen confirmed this behavior, which is definitely wrong, and
that's why the status of this bug was changed to UNCONFIRMED?

I'd really like to see the lost functionality back, because dragging a tab to
create a link or to send a link via text field (e.g. in IM client) is really
useful...



Reproducible: Always
(Reporter)

Comment 1

9 years ago
PS: I know that behaviour is a result of fixing the aforementioned bug 475066, but isn't there a way to change this? To set that drag'n'dropping tab to the desktop will create a shortcut instead of detaching the tab? I'd even prefer an option to completely disable detaching, as it's completely useless for me (and I believe I'm not alone).

Or do you really want to throw overboard all the people who are used to creating shortcuts and sending links like this? This is one of the small details that makes Firefox better than his competitors - a complete "drag'n'drop-ability" of its interface. Pleeease keep it as it was or give current users an option...
i'm not sure it can be implemented since i've not seen the full detach code, but maybe key modifier could allow the user to choose what he wants to do...
like when you drag you usually "move", but holding CTRL you can copy. the same way could allow to determine the action to apply to a tag.
I'm just guessing, really.
PS: btw you cal still drag favicon from the locationbar, and when bug 478070 will be fixed you'll be able to drag also the url.
(Reporter)

Comment 4

9 years ago
Oh, too bad. :-( I know about the favicon dragging, but it's a lot smaller and less comfortable. However, thanks for the explanation, your idea with key modifier seems very reasonable to me. :-)
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 490841
You need to log in before you can comment on or make changes to this bug.