Revise the way words are iterated for spell check

RESOLVED DUPLICATE of bug 355178

Status

()

Core
Spelling checker
--
enhancement
RESOLVED DUPLICATE of bug 355178
9 years ago
9 years ago

People

(Reporter: R Baars, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; nl; rv:1.9.0.10) Gecko/2009042316 Firefox/3.0.10 (.NET CLR 3.5.30729)
Build Identifier: 

To make the best use of spell checking, maximum Hunspell compatibility is desired. This specially refers to the word iterator. Now special characters like dashes and are seen as word separators, as for Dutch, they are not. Also, there is apperantly no exception list for abbreviations, so the spell checker reports them wrongly too.
The request is to make the text iterator different per language, and have some parameter file controlling the way words are seen.
Might have advantage co-operating with OpenOffice.org team on this.

Reproducible: Always

Steps to Reproduce:
1. Set spelling to Dutch,
2. enter the non-words pil-der 
3. note it being accepted as correct, while it is not
4. 


Expected Results:  
pil-der underlined red

offered pil-der as a whole to Hunspell

Updated

9 years ago
Component: General → Spelling checker
Product: Firefox → Core
QA Contact: general → spelling-checker
Version: unspecified → Trunk

Comment 1

9 years ago
You mean word separator.
dashes and apostrophes are problematic (both ' and ’), as are dots after words (for abbreviations)

OpenOffice already handles this correctly, see http://www.openoffice.org/issues/show_bug.cgi?id=64400 (I didn’t read the whole bug, but they speak of n-dashes, which is wrong, at least in Dutch and German, allowed are only hyphens.)
Status: UNCONFIRMED → NEW
Ever confirmed: true

Updated

9 years ago
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 355178
You need to log in before you can comment on or make changes to this bug.