Feature Request: Allow users to forget stored form field value(s)

RESOLVED DUPLICATE of bug 320720

Status

()

Toolkit
Form Manager
--
enhancement
RESOLVED DUPLICATE of bug 320720
9 years ago
8 years ago

People

(Reporter: jason, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.0.10) Gecko/2009042316 Firefox/3.0.10 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.0.10) Gecko/2009042316 Firefox/3.0.10 (.NET CLR 3.5.30729)

When filling out some forms, I am often offered a very long list of auto-complete suggestions. Many times, I would like to clear that list of values that are no longer useful: old phone numbers, old email addresses, etc. Currently, there is no obvious way to do this without completely clearing browser history/cache.

Instead, either:

1. Allow users to right-click on a form input field and select 'Clear stored values for this field'
2. At the bottom of the auto-complete menu, insert an item 'Clear this list'

Reproducible: Always

Steps to Reproduce:
Start typing any text into a form field with a commonly used name ('email' or 'address')
Actual Results:  
List of suggested auto-complete values is displayed

Expected Results:  
List of suggested auto-complete values plus an option to 'Clear this list' is displayed.
You can select individual entries in the popup and press Delete to remove them.
(Reporter)

Comment 2

9 years ago
Holy undocumented feature, Batman!

Perhaps adding a small red 'x' to the end of each entry in the auto-complete list would be a good interface element to inform users of this ability?

Comment 3

9 years ago
undocumented ? 

http://support.mozilla.com/en-US/kb/Form+autocomplete#Deleting_individual_form_entries
Jason, your suggestion in comment 2 is covered by bug 463913

Your initial proposal seems like a duplicate of bug 320720 though.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Component: General → Form Manager
OS: Windows Vista → All
Product: Firefox → Toolkit
QA Contact: general → form.manager
Hardware: x86 → All
Resolution: --- → DUPLICATE
Duplicate of bug: 320720
You need to log in before you can comment on or make changes to this bug.