NS_ScriptErrorReporter should fall back to message when ucmessage is null

RESOLVED WORKSFORME

Status

()

Core
DOM: Core & HTML
P3
normal
RESOLVED WORKSFORME
18 years ago
17 years ago

People

(Reporter: Mike McCabe, Assigned: David Bradley)

Tracking

({dom0})

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

18 years ago
From netscape.public.mozilla.dom:
From: Arne de Bruijn <arbruijn+mozilla@students.cs.uu.nl>
Subject: empty javascript errors


Access to properties of documents on another domain sometimes give empty
javascript errors.

If I understand things correctly this is caused by
js/src/jscntxt.c:js_ReportErrorVA not filling in the ucmessage field in
the JSErrorReport structure, but
dom/src/base/nsJSEnvironment.cpp:NS_ScriptErrorReporter expecting it is.

I don't known if this should be fixed in js_ReportErrorVA or in
NS_ScriptErrorReporter, but it worked for me after I changed
NS_ScriptErrorReporter to use the message argument if the ucmessage
field is NULL (very simple patch available on request :-)

Arne

Comment 1

18 years ago
if you have a fix in hand, attach it when you file the bug please.  Thanks for
flying bugzilla ;).
(Reporter)

Comment 2

18 years ago
Created attachment 13279 [details] [diff] [review]
Make the DOM error reporter tolerate null ucmessage, filename.
(Reporter)

Comment 3

18 years ago
I've asked Arne to add himself to the CC list...

Under what circumstances does js_ReportErrorVA produces a null ucmessage field? 
We should probably fix that too.
Status: NEW → ASSIGNED
(Reporter)

Comment 4

18 years ago
... So how do we reproduce the empty message problem?

Comment 5

18 years ago
Inside the firewall, go to http://maps.mcom.com, type something into the locator 
input field and submit.
Keywords: dom0

Comment 6

17 years ago
Mass-reassigning mccabe's non-JS, non-Rhino bugs to jband (34 total). 

Would like to cc mccabe; but the mass-reassign page does not allow this. 
I'll leave it up to mccabe to decide if he wants to be cc'ed on these - 
Assignee: mike+mozilla → jband
Status: ASSIGNED → NEW

Comment 7

17 years ago
mass reassign of xpconnect bugs to dbradley@netscape.com
Assignee: jband → dbradley
(Assignee)

Comment 8

17 years ago
I'm unable to reproduce this problem.
I figure
1. The map site has changed
2. The problem is covered up, patch was applied and the noise is gone, but the 
problem still exists.
3. The error no longer exists.
I'll keep it, and look into when I have time.
Status: NEW → ASSIGNED
(Assignee)

Comment 9

17 years ago
This appears to not be a problem any more. The code in question has changed 
considerably so I expect it's not an issue in the current code. I'm marking this 
WORKSFORME.
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.