Add extension point to make it easy to intercept URLs

RESOLVED DUPLICATE of bug 599636

Status

Fennec Graveyard
Extension Compatibility
RESOLVED DUPLICATE of bug 599636
9 years ago
7 years ago

People

(Reporter: bcombee, Assigned: mfinkle)

Tracking

Bug Flags:
wanted-fennec1.0 +

Details

(Reporter)

Description

9 years ago
On both the iPhone and Palm Pre, their browser has the ability to intercept some URL forms, like links to Google Maps or Youtube, and redirect them to helper applications on the device that have a better user interface.  This would be a nice capability to put into Fennec.  An easy-to-use extension interface is probably the best way, especially since that could allow development of a user-controlled extension for people customizing their device.

This may already be possible; if so, we should document it in the Fennec developer guide and possibly build our own extension for WinMo or Maemo to take advantage of their helper apps.
Flags: wanted-fennec1.0?
Entirely depends on the capabilities of the "helper" apps. Intercepting URIs is not too difficult in Mozilla apps. But how to launch the helper is more important.
Flags: wanted-fennec1.0? → wanted-fennec1.0+
Assignee: nobody → mark.finkle
Status: NEW → ASSIGNED
We have added code to make this work on Android and Meego (to some degree)
Status: ASSIGNED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 599636
You need to log in before you can comment on or make changes to this bug.