Open Bug 497986 Opened 11 years ago Updated 10 months ago

[Linux] Clear Recent History dialog moves when toggling Details pane

Categories

(Core :: Widget: Gtk, defect, P5)

1.9.1 Branch
x86
Linux
defect

Tracking

()

People

(Reporter: u279076, Unassigned)

References

()

Details

(Whiteboard: [FFT3.5])

Attachments

(1 file)

1.80 MB, application/zip
Details
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1) Gecko/20090612 Firefox/3.5

STR:
1. Click Tools
2. Click Clear Recent History
3. Click the arrow button beside Details to expand
4. Click the arrow button beside Details to collapse
5. Repeat steps 3 & 4 a couple of times

RESULT:
1. Details pane expands/collapses
2. Dialog moves a few pixels to the bottom-right of the screen

EXPECTED:
Just expand/contract the dialog, don't move it.
Attached file Screencast
Here is a screencast of the issue.

This only happens on Linux.  I checked on Mac and Windows and I can't reproduce the behaviour.  It also appears to only happen with the Clear Recent History dialog.  There is a similar UI for Bookmarks Details in the Bookmark Organizer and it does not display this behaviour.
http://www.youtube.com/watch?v=ldXpEq3aRfs

Here's a YouTube link for those that don't want to download the attachment.
I'm unable to reproduce ON Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1pre) Gecko/20090612 Shiretoko/3.5pre...
Component: Bookmarks & History → Private Browsing
QA Contact: bookmarks → private.browsing
Nor on Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1) Gecko/20090612 Firefox/3.5.
Here's the resize code:

http://mxr.mozilla.org/mozilla-central/source/browser/base/content/sanitizeDialog.js#218

Does anyone know if window.resizeBy() is (sometimes) borked?
I just tried this in a VM and definitely cannot reproduce this bug there.  I can however reproduce it on Ubuntu 9.04 32-bit Native from two separate machines.
Yeah, I'm using a VM.
I can also reproduce this on the Bookmarks Properties dialog.

1. Right click a bookmark
2. Click Properties
3. Click the arrow button beside Tags repeatedly
Mozilla/5.0 (X11; U; Linux i686 (x86_64); en-US; rv:1.9.1) Gecko/20090612 Firefox/3.5

Quick update.  I just tried this on my laptop at home and I can't reproduce this bug.  I am running Ubuntu 9.04 64-bit.  Apart from the test machine in the QA lab being 32-bit, it also has an NVidia card with the proprietary driver version 173 installed.  My laptop has an Intel GMA950 graphics chip.  I can't help but wonder if the driver is causing this to happen.
I think this is a widget bug, since the callers don't seem to do anything unusual here.  Moving the bug accordingly.
Component: Private Browsing → Widget: Gtk
Product: Firefox → Core
QA Contact: private.browsing → gtk
Version: 3.5 Branch → 1.9.1 Branch
Adding [FFT3.5] in whiteboard.  Came across this issue during RC1 testing
Whiteboard: [FFT3.5]
You need to log in before you can comment on or make changes to this bug.