Microsummaries do a bunch of work every 15 seconds

RESOLVED DUPLICATE of bug 492794

Status

Firefox Graveyard
Microsummaries
RESOLVED DUPLICATE of bug 492794
9 years ago
2 years ago

People

(Reporter: bz, Unassigned)

Tracking

({perf})

Details

A number of "real web page" profiles I've done recently seem to show the microsummary service taking up somewhere on the order of 10-15% of the time.

I looked at it, and it looks like every 15s we run MSS__updateMicrosummaries, which _should_ be fast because I don't have any microsummaries that I know of... and just isn't.  Is it hitting disk for every call or something?
Flags: blocking-firefox3.6?
Could we see this profile please?  Also, have you changed any microsummary preferences?
I'll send you the next profile I see this in (they're too big to attach to bugzilla)...

And no, I don't think I have.  Certainly not in the testing profile I do the profiling in.
Could this be a regression from bug 492794?
The build I was using predates bug 492794 landing on m-c (pull from two days ago, in fact).  And that patch looks like it might well fix the issue I was seeing!  I'll update and see whether I hit anything like this again.  If I do, I'll reopen.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 492794
Flags: blocking-firefox3.6?
(Assignee)

Updated

2 years ago
Product: Firefox → Firefox Graveyard
You need to log in before you can comment on or make changes to this bug.