BMO's showdependencytree.cgi reports are works of fiction

RESOLVED INVALID

Status

()

bugzilla.mozilla.org
General
RESOLVED INVALID
9 years ago
7 years ago

People

(Reporter: Nelson Bolyard (seldom reads bugmail), Unassigned)

Tracking

Details

(URL)

An examination of  Bug 398944 shows that it depends on 26 other bugs, 
4 of which are still unresolved, and the rest are resolved. 
If we click on the link labeled "Show dependency tree". it takes us to 
https://bugzilla.mozilla.org/showdependencytree.cgi?id=398944&hide_resolved=1
which reports "Bug 398944 depends on 12 open bugs:"  (note: 12, not 4)
However, that page correctly shows us the 4 open bugs.  But it provides a 
link labeled "view as bug list" which takes us to a page that shows 12 bugs.
That page is 
https://bugzilla.mozilla.org/buglist.cgi?bug_id=401587,423093,349382,421946,361957,409415,409876,392024,418644,497832,408681,233118

8 of the 12 bugs in that list do NOT block bug 398944.  
Where do these 8 bogus bugs come from?
The answer here is that the number includes dependencies of dependencies. However, the tree view does not show open bugs which are dependencies of resolved bugs unless you click "Show Resolved". And then, unhelpfully perhaps, the number changes from the number of dependent open bugs to the total number of dependent bugs.

So:

https://bugzilla.mozilla.org/showdependencytree.cgi?id=398944&hide_resolved=1

tells you there are 7 open bugs in the dependency tree somewhere (but doesn't show you them), and

https://bugzilla.mozilla.org/showdependencytree.cgi?id=398944&hide_resolved=0

shows you all the dependent bugs, closed and open, but doesn't tell you how many open ones there are!

This slightly odd situation is the result of being able to resolve a bug which depends on an unresolved bug. Bugzilla has a preference to forbid that, but it's not turned on on b.m.o.

Gerv
marking as invalid (not a bug).
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → INVALID
(Assignee)

Updated

7 years ago
Component: Bugzilla: Other b.m.o Issues → General
Product: mozilla.org → bugzilla.mozilla.org
You need to log in before you can comment on or make changes to this bug.