If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

fails to continue working after Windows wakes from sleep (Disable IDLE, or Work Offline and back to Work Online is workaround)

RESOLVED WORKSFORME

Status

Thunderbird
General
--
critical
RESOLVED WORKSFORME
8 years ago
7 years ago

People

(Reporter: Russell, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

639.01 KB, application/x-zip-compressed
Details
(Reporter)

Description

8 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 6.1; WOW64; Trident/4.0; SLCC2; .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729; Media Center PC 6.0)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.1pre) Gecko/20090612 Shredder/3.0b3pre

Sometimes fails to respond after waking windows.
Does not check for new mail.
Will not restore or shut down - have to use Task Manager to kill it, then restart it.

Reproducible: Sometimes

Steps to Reproduce:
1. have minimised (probable only - it has only happened from that state)
2. put Windows to sleep
3. wake Windows 
Actual Results:  
Cannot restore or close it


Next time it happens I will attempt to locate where it is (presumably) stuck in a loop
Russell, Are you using imap ?
Component: OS Integration → General
QA Contact: os-integration → general
(Reporter)

Comment 2

8 years ago
Yes I am - I should have said also that I abandoned using b2 because of this problem but it did not show in b3pre until today (it did update today).
(Q1) Do you use DHCP for your PC's IP address?
(Q2) Do you enable IDLE?

If both are YES, and your PC's IP address assigned by DHCP has expired(IP address was changed upon wakeup), and it causes connection related issue around IDLE of IMAP, something wrong such as (a) "unable to connect to IMAP server after wakeup" can occur. And, if such situation occurs, it may cause (b) hang(dead lock is suspected) at shutdown. And, some bugs exists for phenomenon like (b) even when normal shutdown.

(Q3) Did you experience problem like (a) after wakeup? Or problem of (b) only? 
"Does not check for new mail" sounds for me problem of (a).
(Reporter)

Comment 4

8 years ago
Q1. I assume I DHCP but the address it connects to never changes (ADSL gateway is not shut down) also the external address rarely changes.
Q2. no idea so it is probably default setting (don't know what it is).

There are no error messages and nothing appears in the event log (I think IP change would be logged).
The computer shuts down without problem - Windows 7 nicely shows anything that is slow to shut down (but nothing was indicated).
I have tried making it sleep since but it starts each time (deadlock is highly probably and almost impossible to make happen).
For (Q2). Check Server Settings/Advanced. Do you check next?
> [? ] Use IDLE command if server supports is "IDLE support"

Another concern.
Some bugs reported problem of (a) & (b) due to "lossed loop back connection" after wakeup, although they were mainly for Windows XP(or Vista?) Home edition.
If you encountered problem next time, check following(at command prompt), please.
> NETSTAT -a -b -n -o
> Session of 127.0.0.1:(N)->127.0.0.1:(N+1) and 127.0.0.1:(N+1)->127.0.0.1:(N1)
> should be paired, because they are loop back connection.

By the way, your case is for X86_64 and new Windows 7.
Which version do you use?
32bits Tb(official build)? Or 64bits Tb for 64bits MS Win(non-official build)?
(Reporter)

Comment 6

8 years ago
I have taken note of that command to run.

I downloaded thunderbird-3.0b3pre.en-US.win32.installer.exe 10 June 2009 11:28AM (GMT +10) from http://ftp.mozilla.org/pub/mozilla.org/thunderbird/nightly/latest-trunk/
As I said it updated this morning (my time) presumably the same version (but later daily build).
Windows 7 RC Build 7100 with all updates applied.
If problem is "Does not check for new mail after wakeup" and if it was cause by issues like (Q1) or (Q2), next is known by some bugs.
  The problem is resolved by go "Work Offline" and back to "Work Online" again.
After check by NETSTAT, check above if you encounter problem again, please.
(Reporter)

Comment 8

8 years ago
I have 4 times today but each time it started correctly - I think it knows that I am trying to catch it not working!
I tested running the NETSTAT check so that I know what to expect.
The problem does not allow me to restore so I cannot tell if it won't check for new mail.
Hopefully (don't know that is the right term) it will fail again soon - I will keep trying it.
(Reporter)

Comment 9

8 years ago
Created attachment 383373 [details]
ProcExp images and netstat results

While it was failing to respond did netstat -results=netstat_bad.txt
Using ProcessExplorer I located 2 instances running
1448 - see TID1080 & TID5908 (little/no activity)
5832 - the active instance (I printed many thread stack lists particularly of any that looked to be active).
     - I then suspended it threads 5628 & 6008 at which time shreader would restore though (naturally) was not responding (actually I think 5628 may have done it).
Hope this helps
(Reporter)

Comment 10

8 years ago
Again failed - this time when not minimised.
Shreader is just frozen (not responding).
I may be wrong but it appears to happen more regularly when the computer goes to sleep on timeout (instead of manually putting it to sleep).

I think this is the relevent section of the NETSTAT report
 [ccSvcHst.exe]
  TCP    127.0.0.1:53563        127.0.0.1:53564        ESTABLISHED     1104
 [thunderbird.exe]
  TCP    127.0.0.1:53564        127.0.0.1:53563        ESTABLISHED     1104
 [thunderbird.exe]
  TCP    127.0.0.1:53565        127.0.0.1:53566        ESTABLISHED     1104
 [thunderbird.exe]
  TCP    127.0.0.1:53566        127.0.0.1:53565        ESTABLISHED     1104
 [thunderbird.exe]
  TCP    127.0.0.1:53632        127.0.0.1:2869         ESTABLISHED     4092
Two pairs of loop back connection is active.
    127.0.0.1:53563 -> 127.0.0.1:53564  &  127.0.0.1:53564 -> 127.0.0.1:53563
    127.0.0.1:53565 -> 127.0.0.1:53566  &  127.0.0.1:53566 -> 127.0.0.1:53565
So your problem is irrelevant to loop back connection.

Can you disable "IDLE support" in your daily use?
> [ ? ] Use IDLE command if server supports
Does your problem frequently occur when "IDLE support" is disabled?
(Reporter)

Comment 12

8 years ago
I have no idea where to find any IDLE support settings - who, what and where are they controlled?
Read Comment #5, please.
(Reporter)

Comment 14

8 years ago
Presumably it refers to some IMAP IDLE settings but I have no controls over any of the 4 or 5 IMAP servers.

I suppose the answer must be no I cannot disable (or enable) it.
I said about Tb's support of IDLE command(use IDLE command or not when server supports IDLE), not server side IDLE support. If you uncheck the setting in Server Settings/Advanced, Tb doesn't issue IDLE command.
If IDLE command is disabled, "new mail notification form server via IDLE" becomes imposisible, and periodical folder click or setting of "automatic mail checking" will be required, if you are currently utilizing IDLE in daily use.
Can you afford to "no IDLE command use by Tb"?
(Reporter)

Comment 16

8 years ago
I have now disabled it on all accounts - will see what happens.
(Reporter)

Comment 17

8 years ago
So far so good - since disabling it there have been no problems.
I know it might be a bit soon but it has had 2 oportunities to fail (once a day the computer normally goes to sleep by itself) and both times it has kept working.
Developers,

Note that this issue is apparently causing on-shutdown crashes of 3.0beta on Mac.  I'm currently testing to see if IDLE=off stops these crashes; will report back.
(In reply to comment #18)
> Developers,
> 
> Note that this issue is apparently causing on-shutdown crashes of 3.0beta on
> Mac.  I'm currently testing to see if IDLE=off stops these crashes; will report
> back.

Can you repport back now ?

Comment 20

8 years ago
I have the same behavior on MacOS X 10.6.2 with Thunderbird 3.0.1. Disabling IMAP IDLE or switching to offline mode and back to online mode after wake from sleep resolves the issue. 

Sometimes also an email cannot be saved to the sent folder after sending an email after wake from sleep, thunderbird times out and rises an error message, that it could not save the email in the sent folder.
Summary: fails to continue working after Windows wakes from sleep → fails to continue working after Windows wakes from sleep (Disable IDLE, or Work Offline and back to Work Online is workaround)
related to Bug 458827?   Hang if my IP changes after sleep (Disable of IDLE command use is a workaround
Josh has the situation improved ?
lichtinger, Josh, do you see this probglem when using version 3.1? 
If you do, we'll move this and hopefully bug 458827 along
Whiteboard: closeme 2010-10-15

Comment 24

7 years ago
(In reply to comment #23)
Using Thunderbird/3.1.4 on OS X now. This Bug seems fixed with this version.
WFM per comment 24.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WORKSFORME
Whiteboard: closeme 2010-10-15
You need to log in before you can comment on or make changes to this bug.