Bookmarks & history blank, url bar won't work

RESOLVED DUPLICATE of bug 497792

Status

()

RESOLVED DUPLICATE of bug 497792
9 years ago
9 years ago

People

(Reporter: mike, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8) Gecko/20051111 Firefox/1.5
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-GB; rv:1.9.0.11) Gecko/2009060214 Firefox/3.0.11

Having upgraded to 3.0.11 I found that Firefox seemed to have lost my bookmarks and History. Also when I entered an URL in the bar it didn't respond. 

Reproducible: Always

Steps to Reproduce:
Re-installed Firefox 3.0.11 - no joy
I went through the process of deleting the Places file - no joy. 
I tried to import a backup file file from the History window but Firefox reported "Unable to restore backup"

Now I use a hard link to point to my Firefox folder in my Application folder to another folder on a network attached machine. This has worked fine until this upgrade.
So I took the hard link folder out of Application Support folder and Firefox started working again but obviously without all by bookmarks etc.
So I copied the appropriate files across a few at a time checking that Firefox still worked and rebuilt a fully working and restored system with the Firefox folder on my local drive. I then copied that onto my 'server' and created a hard link to it back to by Application Support folder and the problem immediately reoccurred.
So it would appear as if something in the last upgrade has broken the ability to have the Firefox folder on another machine.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 497792
You need to log in before you can comment on or make changes to this bug.