Url for bookmark keyword not shown in location bar dropdown

RESOLVED DUPLICATE of bug 212605

Status

RESOLVED DUPLICATE of bug 212605
10 years ago
10 years ago

People

(Reporter: bugzilla.spam2, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1pre) Gecko/20090611 SeaMonkey/2.0b1pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1pre) Gecko/20090611 SeaMonkey/2.0b1pre

I use the bookmark keyword "rtz" and have the title "Neues von LGs 480-Hertz-Fernsehern" in my history data. 
Typing "rtz" in the location bar SeaMonkey shows the url for the title but not the url for the bookmark keyword in the location bar dropdown while searching history and bookmarks.

Doing the same in a recent trunk build from Firefox has a different result. In Firefox the urls for the bookmark keyword and the title is shown. The url for the bookmark keyword is even shown as the first result in the location bar dropdown.

For both SeaMonkey and Firefox browser.urlbar.default.behavior is set to 0.

In my opinion SeaMonkey should show the same behavior as Firefox.

Reproducible: Always

Comment 1

10 years ago
That's not possible right now, as the old bookmarks system we're using is not available to the location bar. I guess this will not really be possible to solve without switching to places bookmarks, which is only planned after SeaMonkey 2.0.
(Reporter)

Comment 2

10 years ago
But bookmark keywords in general are working in recent trunk builds. So bookmarks.html is parsed somewhere. Probably after hitting enter in location bar at the moment. 
Shouldn't it be possible to start parsing bookmarks.html already while someone is typing in the location bar?

Comment 3

10 years ago
In theory, with a week of work by someone, something might be possible. I practice, it isn't, as the location bar autocomplete results are generated by the places code, which doesn't have any knowledge of our bookmarks.
It's probably easier to convert us to places bookmarks than to implement this with our ancient bookmarks system.
Severity: normal → enhancement
Version: unspecified → Trunk
Severity: enhancement → normal
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Version: Trunk → unspecified
Duplicate of bug: 212605
You need to log in before you can comment on or make changes to this bug.