Backgrounds which are made fixed are not being rendered as fixed. The background is moving with the text, instead of not moving.

RESOLVED INVALID

Status

()

--
major
RESOLVED INVALID
10 years ago
10 years ago

People

(Reporter: SaintlyMic, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.11) Gecko/2009060215 Firefox/3.0.11 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.11) Gecko/2009060215 Firefox/3.0.11 (.NET CLR 3.5.30729)

I created my websites so that the background is fixed. 
The text on my websites is supposed to flow over a fixed background.
Firefox is not rendering my websites the way they were created to be rendered. 
Internet Explorer renders my websites correctly.

Reproducible: Always

Steps to Reproduce:
Very very simple. 
Go to http://www.saintlymic.com/ 
Now, scroll down and you will see that Firefox is not rendering my background as fixed, so that the text scrolls over my fixed background.
Actual Results:  
The background is not being rendered properly, and the text seems to move with the background. 
I created my websites to have a fixed background, but Firefox does not render them correctly.

Expected Results:  
I expect Firefox to render my web pages correctly, just as Internet Explorer renders my web pages correctly. 
I would like to see the text on my sites to flow smoothly over my fixed background.

Is there a reason why Firefox has been programmed to not allow text to flow over a fixed background? 
If there is, then please explain to me why Firefox does not render fixed backgrounds as fixed backgrounds. 
Could it be because no one has brought this to your attention before now? 
Firefox is my favorite browser, and I use Firefox almost exclusively! 
If it is possible, please fix this problem and allow websites created with fixed backgrounds to render as fixed backgrounds in Firefox. 
Thank you very much! 
SaintlyMic 
SaintlyMic.com
|bgproperties="fixed"| is an IE only extension.
Use CSS rule |background-attachment: fixed| instead (IE also understands it).
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → INVALID
(Reporter)

Comment 2

10 years ago
Thank you very much for such a quick response! 
Now, I need to learn CSS, LOL.
Firefox has again proven to be a much better browser than Internet Explorer.
Firefox help support is so much better than IE help support.
It is nice to know that this bug report has nothing to do with there being a bug in FF.
You need to log in before you can comment on or make changes to this bug.