"New Task" button state doesn't change immediately with the calendar state

RESOLVED DUPLICATE of bug 518112

Status

Calendar
Tasks
RESOLVED DUPLICATE of bug 518112
9 years ago
8 years ago

People

(Reporter: Jakub 'Livio' Rusinek, Unassigned)

Tracking

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; pl; rv:1.9.0.11) Gecko/2009060214 Firefox/3.0.11
Build Identifier: 

"New task" state is confusing, regardless the task support.

Reproducible: Always

Steps to Reproduce:
1. use a calendar, which doesn't support tasks. disable and RTM providers etc.
2. open tasks tab.
3. notice disabled "new task" button. right click inside tasks list. notice "new task" going enabled, but useless. click inside textbox with "Please Select a Calendar that Supports Tasks". notice button going disable.
Actual Results:  
state depends on clicked component.

Expected Results:  
state undependent on clicked component.

Comment 1

9 years ago
Do you use Sunbird or Lightning? What version?
(Reporter)

Comment 2

9 years ago
Currently I'm using Lightning 1.0pre (build 20090613030915) on nightly
Thunderbird.
With Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1.5) Gecko/20091130 Lightning/1.0b1pre Thunderbird/3.0 I see following behavior: The "New Task" button doesn't change immediately with the "calendar state". -> Confirmed NEW
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Linux → All
Hardware: x86 → All
Summary: "New task" button state case → "New Task" button state doesn't change immediately with the calendar state
Whiteboard: [good first bug]

Comment 4

8 years ago
I think the same problem concerns all the "new task" and "new event" buttons in the interface and every menu entries related to new task/event in main menu.
The same issue happens with "new event" and "new task" command for calendar in read only mode or switched off as reported in bug 518112.
Although this is the older bug, bug 518112 has more details.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Whiteboard: [good first bug]
Duplicate of bug: 518112
You need to log in before you can comment on or make changes to this bug.