Closed Bug 498194 Opened 11 years ago Closed 11 years ago

Digital piano causes Shiretoko/Firefox 3.5 to crash. [@ oggplay_buffer_set_last_data]

Categories

(Core :: Audio/Video, defect, critical)

1.9.1 Branch
x86
Windows Vista
defect
Not set
critical

Tracking

()

RESOLVED DUPLICATE of bug 496581

People

(Reporter: deprecationmail, Unassigned)

References

()

Details

(Keywords: crash)

Crash Data

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; sv-SE; rv:1.9.1pre) Gecko/20090601 Shiretoko/3.5pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; sv-SE; rv:1.9.1pre) Gecko/20090601 Shiretoko/3.5pre

So, I tried http://evilbrainjono.net/piano.html and clicking with the mouse worked, although a bit choppy. But when I tried with several of my keyboard keys Firefox/Shiretoko crashed. I've been able to reproduce this several times now.

Reproducible: Always

Steps to Reproduce:
1. Enter http://evilbrainjono.net/piano.html
2. Try playing the piano with several keys
3. Experience crashes? (If not, try playing with your mouse first)
Actual Results:  
The browser freezes and then crashes.

Expected Results:  
Several tunes should play without any freezes or crashes.
Version: unspecified → 3.5 Branch
This time I got Firefox to crash when using just the mouse by clicking a lot too.
Last one:

http://crash-stats.mozilla.com/report/pending/ed6b1da9-3bd1-4ace-8e3f-57ed62090614

This time reproduced in Safe mode.
Signature	oggplay_buffer_set_last_data
UUID	ed6b1da9-3bd1-4ace-8e3f-57ed62090614
Time 	2009-06-14 03:07:57.897377
Uptime	65
Last Crash	621 seconds before submission
Product	Firefox
Version	3.5pre
Build ID	20090601044045
Branch	1.9.1
OS	Windows NT
OS Version	6.0.6001 Service Pack 1
CPU	x86
CPU Info	GenuineIntel family 6 model 15 stepping 6
Crash Reason	EXCEPTION_ACCESS_VIOLATION
Crash Address	0xc
User Comments	
Processor Notes 	
Crashing Thread
Frame 	Module 	Signature [Expand] 	Source
0 	xul.dll 	oggplay_buffer_set_last_data 	media/liboggplay/src/liboggplay/oggplay_buffer.c:150
1 	xul.dll 	oggplay_step_decoding 	media/liboggplay/src/liboggplay/oggplay.c:715
2 	xul.dll 	nsOggDecodeStateMachine::Run 	content/media/video/src/nsOggDecoder.cpp:1522
3 	xul.dll 	nsThread::ProcessNextEvent 	xpcom/threads/nsThread.cpp:510
4 	xul.dll 	nsThread::ThreadFunc 	xpcom/threads/nsThread.cpp:254
5 	nspr4.dll 	_PR_NativeRunThread 	nsprpub/pr/src/threads/combined/pruthr.c:426
6 	nspr4.dll 	pr_root 	nsprpub/pr/src/md/windows/w95thred.c:122
7 	mozcrt19.dll 	_callthreadstartex 	obj-firefox/memory/jemalloc/src/threadex.c:348
Component: General → Video/Audio
Keywords: crash
Product: Firefox → Core
QA Contact: general → video.audio
Summary: Digital piano causes Shiretoko/Firefox 3.5 to crash. → Digital piano causes Shiretoko/Firefox 3.5 to crash. [@ oggplay_buffer_set_last_data]
Version: 3.5 Branch → Trunk
Duplicate of bug 496581? If so, it's fixed on trunk already.
Status: UNCONFIRMED → RESOLVED
Closed: 11 years ago
Resolution: --- → DUPLICATE
Version: Trunk → 1.9.1 Branch
Duplicate of bug: 496581
Which trunk? I'm running Shiretoko which is supposed to be latest 3.5/1.9.1 trunk, right?
Status: RESOLVED → UNCONFIRMED
Component: Video/Audio → General
Product: Core → Firefox
Resolution: DUPLICATE → ---
Version: 1.9.1 Branch → 3.5 Branch
Please be careful not to clobber status updates when you update bugs that others have also updated recently.

Shiretoko (1.9.1) is released from the mozilla-1.9.1 branch.  Trunk is mozilla-central (aka Minefield nightlies).  Bug 496581 is fixed on trunk, but not yet on branch.  It's waiting on approval for landing on the 1.9.1 branch.
Status: UNCONFIRMED → RESOLVED
Closed: 11 years ago11 years ago
Component: General → Video/Audio
Product: Firefox → Core
Resolution: --- → DUPLICATE
Version: 3.5 Branch → 1.9.1 Branch
Duplicate of bug: 496581
Crash Signature: [@ oggplay_buffer_set_last_data]
You need to log in before you can comment on or make changes to this bug.