If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Add-on Collector - using %%amo_host%% in url

RESOLVED DUPLICATE of bug 497584

Status

addons.mozilla.org Graveyard
Collector Extension
--
major
RESOLVED DUPLICATE of bug 497584
8 years ago
2 years ago

People

(Reporter: Luke Sheldrick, Unassigned)

Tracking

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1b4) Gecko/20090427 Fedora/3.5-0.20.beta4.fc11 Firefox/3.5b4
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1b4) Gecko/20090427 Fedora/3.5-0.20.beta4.fc11 Firefox/3.5b4

Using Fedora 11, FF 3.5 B4. 

Using Add-on Collector https://addons.mozilla.org/en-US/firefox/downloads/latest/11950/addon-11950-latest.xpi

When you try to login, or register, the host/url used is https://%%amo_host%%/users/register and the %%amo_host%% variable is not populated, rending the add-on unusable.

Reproducible: Always

Steps to Reproduce:
1. Install Fedora 11, update. 
2. Install FF 3.5 B4, and Add-on Collector from the above URL.
3. Try to register or login from the Add-on. 
Actual Results:  
Taken to a new tab with https://%%amo_host%%/users/register which naturally doesn't work. 

Expected Results:  
%%amo_host%% to be populated and taken to the correct login page.
(Reporter)

Updated

8 years ago
Component: General → Collections
Product: Firefox → addons.mozilla.org
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 497584
Component: Collections → Collector Extension
QA Contact: general → collector-extension
(Assignee)

Updated

2 years ago
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.