Crash in JS_EvaluateUCInStackFrame (jsdbgapi.cpp line 1245)

RESOLVED DUPLICATE of bug 497998

Status

()

Core
JavaScript Engine
--
major
RESOLVED DUPLICATE of bug 497998
9 years ago
9 years ago

People

(Reporter: Karsten Düsterloh, Unassigned)

Tracking

({regression})

1.9.1 Branch
x86
Linux
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

9 years ago
Created attachment 383185 [details]
gdb stack 

SeaMonkey debug build, i.e. m-c 1.9.1 branch, plus Venkman.
Hitting any breakpoint crashes SM with the attached stack:

#0  0x00007f2d2ccb8095 in raise () from /lib/libc.so.6
#1  0x00007f2d2ccb9af0 in abort () from /lib/libc.so.6
#2  0x00007f2d30aa55ad in JS_Assert (s=0x7f2d30acd1c3 "cx->fp", file=0x7f2d30accf60 "/home/kd/projekte/mozilla/mozilla.org/src/trunk/mozilla/js/src/jsdbgapi.cpp", ln=1245) at /home/kd/projekte/mozilla/mozilla.org/src/trunk/mozilla/js/src/jsutil.cpp:69
#3  0x00007f2d309c4c32 in JS_EvaluateUCInStackFrame (cx=0x7f2d15c27400, fp=0x7fff39140e70, chars=0x7f2d1ec58f80, length=170, filename=0x7f2d15d7bd00 "x-jsd:value-record", lineno=1, rval=0x7fff3913c618) at /home/kd/projekte/mozilla/mozilla.org/src/trunk/mozilla/js/src/jsdbgapi.cpp:1245
...

The crashing assertion was introduced by bug 496824.

Example steps to reproduce:
- start SM debug build with -venkman -browser
- tell Venkman to break in the onunload handler of the browser window
- close the browser window
=> Crash
(Reporter)

Updated

9 years ago
Summary: Crash in JS_EvaluateUCInStackFrame line 1245 → Crash in JS_EvaluateUCInStackFrame (jsdbgapi.cpp line 1245)
(Reporter)

Updated

9 years ago
Version: 1.8 Branch → 1.9.1 Branch

Updated

9 years ago
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 497998
You need to log in before you can comment on or make changes to this bug.