initial persona not set from cookie in Mac/Linux guest sessions

RESOLVED FIXED

Status

Mozilla Labs Graveyard
Personas Plus
RESOLVED FIXED
9 years ago
2 years ago

People

(Reporter: myk, Assigned: myk)

Tracking

Details

(Assignee)

Description

9 years ago
The initial persona is not getting set from the initial_persona cookie set by the website in Mac/Linux guest sessions.  Here are steps to reproduce from Flore in the discussion group:

I tested this new release on Firefox (3.5b99 on Leopard) with a new
profile (Guest account on MacOSX)
* I went to getpersonas
* I clicked on "Get Personas now!" button on Fireflies page and the
cookie "initial_persona" was created with the correct persona
(Fireflies)
* I refused to install the version from AMO and installed the 1.2.1RC3
* I restarted Firefox and the persona "groovy Blue" was applied :'(
I checked several times (with different personas), If I close Firefox
before installing personas, the cookie is kept and content is correct.
But, it's not taken into account the first time personas is run. I
don't know why.

I confirmed this behavior on both Mac and Linux, although I'm not sure why I didn't see it in my testing.  Looking at the code, it looks like the Persona service is being instantiated, then it sets the persona to the initial persona set in the cookie, but then the chrome code in personas.js sets the persona to the initial persona set in preferences.

If that's the problem, then the fix is simple... move the "initial persona from preferences" code to the service and only execute it if there is no cookie.
(Assignee)

Comment 1

9 years ago
(In reply to comment #0)
> I confirmed this behavior on both Mac and Linux, although I'm not sure why I
> didn't see it in my testing.

It's because my test case steps didn't include resetting the extensions.personas.lastversion pref, and the bug manifests itself when that pref is at its default value.

Fixed by changeset http://hg.mozilla.org/labs/personas/rev/bbda189b9631.  I've updated the development build to include the fix:

http://people.mozilla.com/~cbeard/personas/dist/personas-dev.xpi

I also spun a new RC for the 1.2.1 release that includes this fix:

http://people.mozilla.com/~cbeard/personas/dist/personas-v1.2.1rc4.xpi

This bug breaks the new feature for setting the initial persona from a cookie set by the gallery, so this is a blocker for the 1.2.1 release.
Status: ASSIGNED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
I tested on a new profile and this bug is fixed on personas 1.2.1rc4.
Product: Mozilla Labs → Mozilla Labs Graveyard
You need to log in before you can comment on or make changes to this bug.