Closed Bug 498330 Opened 11 years ago Closed 11 years ago

make distclean doesn't work with --disable-compile-environment

Categories

(Firefox Build System :: General, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED
mozilla1.9.2a1

People

(Reporter: florian, Assigned: florian)

References

Details

Attachments

(1 file)

Attached patch Patch v1Splinter Review
When --disable-compile-environment is provided to the configure script, the sub-configures in nsprpub and js/src are not executed.
make distclean fails while recursing through the tree when reaching the js/src folder, because js/src/config/autoconf.mk is missing.

I don't think recursing through the whole tree is needed when the compile environment is disabled. The attached patch makes the root Makefile.in ignore the application provided build.mk file when the compile environment is disabled.
Attachment #383262 - Flags: review?(ted.mielczarek)
I'm not really sure what the intended behavior is if you "make anything" in the top-level dir and have --disable-compile-environment. I'm not sure I'd expect anything to work.
When using --disable-compile-environment, I suppose the only thing used is the Makefile in browser/locales (or Makefiles in other locale folders).

I haven't found any documentation suggesting using the toplevel makefile, but once I forgot to define the OBJDIR in my mozconfig, and after I fixed the mozconfig, the configure failed and asked me to make distclean, which didn't work. I'd expect to be able to "undo" the effects of configure.
Comment on attachment 383262 [details] [diff] [review]
Patch v1

Ok, a little weird, but I'll buy that.
Attachment #383262 - Flags: review?(ted.mielczarek) → review+
http://hg.mozilla.org/mozilla-central/rev/05734cb6e140
Assignee: nobody → florian
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla1.9.2a1
Blocks: 543297
Flags: in-testsuite-
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.